Closed Bug 203439 Opened 17 years ago Closed 15 years ago

slow scrolling due to hidden, fixed-position elements

Categories

(Core :: Web Painting, defect, P2)

x86
Windows 98
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: bustanaamio, Assigned: roc)

References

(Blocks 1 open bug, )

Details

(Keywords: perf)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a; MultiZilla v1.4.0.1) Gecko/20030425
Build Identifier: http://komodo.mozilla.org/pub/mozilla/nightly/2003-04-25-12-1.3.1/

Scrolling down the page renders very badly, visiting the page's side menus
corrects the problem. 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.




The 1.0-branch has this corrected nowadays I think, it wasn't at the time of the
original release. The page is used very often as a reference for checking out if
new builds are 'any good'.
OS/2 trunk 2003032009

Yikes! How sluggish! What a CPU hog! I wonder if this is related to bug 167884?
Status: UNCONFIRMED → NEW
Ever confirmed: true
2003042112 on Linux won't even render this page. Mandrake 9.0/KDE 3
Reproduced: win98 build 2003042004
The site has dozens of visibility:hidden fixed-positioned elements... Doing this
fast while complying with the CSS spec is an interesting theoretical problem...
(the 1.0 branch violates the CSS spec here, so....)
Assignee: asa → roc+moz
Component: Browser-General → Layout: View Rendering
QA Contact: asa → ian
Is this related to/dupe of bug 200863?
Looks like the same issue with a shitload more fixed-pos elements here...

There was also a bug matti filed on this issue, iirc....
Depends on: 200863
bz: dupe it to bug 198062 ?
Actaully, let's make this one block the others since it has the most egregious
testcase.... if this gets fixed somehow, we retest the other ones.
Blocks: 198062, 200863
No longer depends on: 200863
oooh boy

On SyncFrameViewAfterReflow etc we could hide any widget whose CSS element is
"visibility:hidden" (but NOT hide the view). Then if there is actual visible
child content fast scrolling will be disabled (in the position:fixed case) but
it will still render correctly AND in the normal case everything will be good.
Priority: -- → P2
Hmm, the page isn't even rendering correctly either.
Blocks: 203448
Keywords: perf
You dont even need to scroll this page, click on the document and then on the
url bar, you will se the what the attached image shows.
*** Bug 206640 has been marked as a duplicate of this bug. ***
Is this a regression?
Summary: performance sluggish on Finnish CSS-tutorial page → performance sluggish on Finnish CSS-tutorial page due to fixed positioning
Blocks: 100951
Is this a dup of bug 201307, or is it a bug separate because the elements on
this page are hidden?
Summary: performance sluggish on Finnish CSS-tutorial page due to fixed positioning → slow scrrolling bugs
Summary: slow scrrolling bugs → slow scrolling due to hidden, fixed-position elements
*** Bug 216997 has been marked as a duplicate of this bug. ***
I'm not positive that bug 216997 is a duplicate of this bug since it occurs 
only on MacOS. 
Well, I think this is another bug that has hugely benefited from the fix from
bug 243726.
Scrolling is slow in a 2004-11-04 trunk build, but this has improved
tremendously in the 2004-11-05 (and still fine with the 2004-11-21 trunk build)

So I'm inclined to call this bug FIXED. 
Depends on: 243726
I still see Linux issues on that testcase, but those may be covered by other
bugs already.  Given that this bug was reported on windows, marking it fixed
seems reasonable.
Ok, marking fixed then.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.