bottom border of div box overlaps with following one, using certain font (Lucida Console)

RESOLVED WORKSFORME

Status

()

Core
Layout: Block and Inline
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Malte Rücker (mbr), Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030425

In the testcase you should see six boxes with red borders around every of them
and a different number of text lines in them. In Mozilla there is no border
below box #2 and the borders below #3 and #5 atick together with the top borders
of the following boxes. I could reproduce this only when using the font "Lucida
Console" for the text in the boxes, maybe there are others. Removing or adding
text lines to the boxes changes where (i.e. on the bottom-border of which box)
and sometimes if the bug occurs at all.

Reproducible: Always

Steps to Reproduce:
1. Just load the page. The font mentioned above (Lucida Console) has to be
installed on your system.
Actual Results:  
Box #2 has no bottom border, the bottom-border of box #3 (#5) sticks together
with  the top border of box #4 (#6) resulting in one bigger border.

Expected Results:  
All boxes should have 1px border on every side and one pixel space between them.
(Reporter)

Comment 1

15 years ago
Created attachment 121785 [details]
testcase showing bug with six div boxes
Confirming. It looks like some sort of rounding error in calculating heights, maybe.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
Created attachment 123450 [details]
testcase using absolute positioning

I just discovered something similar and attached my own test case.  Using the
"Lucida Console" font at 10pts, I have no problem with a normal DIV. 
Positioning the DIV absolutely, however, removed 1 pixel's height from my lower
border.

Changing the font-size to 12pt shows the whole lower border.

At 10pt, using a 1em padding-bottom, my lower border goes back to 1px.

At 10pt, using a 10px padding-bottom, my lower border is working right (2px).

Comment 4

15 years ago
Created attachment 128934 [details]
Test case for misrender of lower border.

Comment 5

11 years ago
Seems to work fine for me with FF 2.0 and trunk.
Assignee: layout.block-and-inline → nobody
QA Contact: ian → layout.block-and-inline
(Reporter)

Comment 6

9 years ago
I can't reproduce any of the test cases in FF 3.5.5.
=> WFM
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.