Image in frame with same height (in pixels) as the frame gets "chopped" at the bottom.

RESOLVED DUPLICATE of bug 191720

Status

()

Core
Layout: HTML Frames
RESOLVED DUPLICATE of bug 191720
15 years ago
4 years ago

People

(Reporter: Tom Williams, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030424
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030424

I've got a page with 4 frames and the upper frame has an image with the same
height, in pixels, as the frame itself and the bottom of the image gets
"chopped" resulting in the imagemap along the bottom edge being hidden.

I've created a testcase and will attach screenshots to illustrate the behavior.

Reproducible: Always

Steps to Reproduce:
1.Load the attached testcase.
2.
3.

Actual Results:  
The image in the TOP frame gets "chopped" at the bottom.

Expected Results:  
The image in the TOP frame should not get "chopped".
(Reporter)

Comment 1

15 years ago
Created attachment 121805 [details]
HTML testcase illustrating the problem.

This ZIP file contains the HTML used to recreate the problem.
(Reporter)

Comment 2

15 years ago
Created attachment 121806 [details]
Screenshot of test HTML in Mozila 1.4b on Linux

This is a screenshot of how the test HTML looks in Mozilla 1.4b on Linux.
(Reporter)

Comment 3

15 years ago
Created attachment 121807 [details]
Screenshot of test HTML in Opea 6 on Linux

This is a screen shot of the same test HTML in Opera 6 on Linux. Notice the
imagemap along the bottom is not "chopped".
Attachment #121805 - Attachment mime type: application/octet-stream → application/zip
There is a <p> containing the image.  This has a top margin.  We have a quirk to
drop the top margin if the <p> is the first thing in the document, but in this
case the <p> is inside a <div>, with the <div> being the first thing.

So the image is pushed down by the size of the <p> margin.

This is a duplicate of a WONTFIX bug.
Whiteboard: DUPEME
Duping against bug 191720, which isn't precisely this but also results from the
limited scope of the <p>-margin-removing quirk.

*** This bug has been marked as a duplicate of 191720 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.