Math characters like ∀ display inconsistently with XFT

RESOLVED DUPLICATE of bug 128153

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 128153
15 years ago
4 years ago

People

(Reporter: Jason McCarty, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030327 Debian/1.3-4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030327 Debian/1.3-4

Lines of text with some math characters in the listed page either render as
garbage, or cause surrounding characters to disappear. Characters that cause the
problem include ∀, 2203, and 2208, which are the forall, exists, and set
membership math characters. Specifically, those characters are rendered garbled,
then if I highlight them, they are rendered correctly, but the left square
brackets near them disappear and reappear depending on where the selection
extends to.


Reproducible: Always

Steps to Reproduce:
1. View the page at the above URL.
2. In the first inset quote on that page, some of the math characters are garbled.
3. Highlighting the characters makes some of them appear or disappear.
Jason, are you using an xft build or a regular one?
(Reporter)

Comment 2

15 years ago
I'm using xft, via Debian's mozilla-xft package. I just checked, and it looks
like the problem doesn't occur without xft support enabled.
Thanks for checking.  ;)

Over to blizzard.
Assignee: font → blizzard
Summary: Math characters like ∀ display inconsistently → Math characters like ∀ display inconsistently with XFT
Whiteboard: DUPEME
(Reporter)

Comment 5

15 years ago
Created attachment 121858 [details]
image of problem

Well, this could be the same bug, but I'm seeing character corruption instead
of misplacement. In the attached file, the top part shows the initial
rendering, the middle shows what happens if I highlight and unhighlight the
text (a change in focus also causes it), and the bottom image shows what
happens when I highlight a certain space. This is all of that first inset
quote.
I also noticed that the math characters don't have antialising like the
characters around them do.
(Assignee)

Comment 6

15 years ago
dup

*** This bug has been marked as a duplicate of 128153 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.