[Tree Regression] When resizing the columns only headers get resized, the contents of the tree are not being resized.

RESOLVED FIXED in M13

Status

()

Core
XUL
P3
normal
RESOLVED FIXED
18 years ago
10 years ago

People

(Reporter: Gennady Feldman, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When I resize the columns only the column headers are being resized. The tree
content is not being resized. For example: when you open Manage Bookmarks and
you resize the URL column (I grab a splitter in between the URL column and
Custom Key column) the actual urls from bookmarks are not being resized. The
column headers do resize, but the content is not being refreshed to accomodate
for the updated column width of the URL column. It seems that all content to the
right of the URL column does follow the column resize movement. But the actual
column which is being resized is not updated.

(Note: The column is being resized, since the column Custom Key is being dragged
around, the URL column should resize itself. Also to note that when column
headers are resized the text is not clipped, so it overflows the column width
and draws on top of the next column.)
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: [Tree] When resizing the columns only headers get resized, the contents of the tree are not being resized. → [Tree Regression] When resizing the columns only headers get resized, the contents of the tree are not being resized.
Target Milestone: M12
(Assignee)

Comment 1

18 years ago
This used to work great.  Someone checked something in to regress this.

Updated

18 years ago
Assignee: trudelle → hyatt
Status: ASSIGNED → NEW
Target Milestone: M12 → M13

Comment 2

18 years ago
reassigning to hyatt as p3 for m13
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 3

18 years ago
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL

Comment 4

18 years ago
Massive QA Contact update.
QA Contact: ckritzer → jrgm

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.