All users were logged out of Bugzilla on October 13th, 2018

Mozilla Crashes (closes itself) upon loading ANY Java Plugin (like Yahoo Games)

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: shassouneh, Assigned: joshua.xia)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

When Loading a Java Applet from Within Mozilla 1.3 (SuSE Linux 8.1 Pro), Mozilla
immediately closes.
Note: The JRE plugin has been set up properly by linking to libjavaplugin.so NOT
copying it.

Reproducible: Always

Steps to Reproduce:
1.Start Mozilla, and go to chat.yahoo.com
2. provide a login
3.Click through until you find a chat room
4.When the Java applet begins loading,k Mozilla will close immediately

Actual Results:  
Mozilla Closes itself

Expected Results:  
Loaded the Java plug in and operated the site normally.

Comment 1

16 years ago
Works fine for me. Does the plugin appear in the listings of "about:plugins" ?

Are you using the right plugin - it's not libjavaplugin.so but 
libjavaplugin_oji.so you should be linking to ?

Have you a gcc 3.x compiled mozilla and linking to gcc 2.95.x plugin ?

Did it ever work before ?

This is almost certainly an issue with your (mis)setup.
=> Oji
Assignee: peterlubczynski → joshua.xia
Severity: major → critical
Component: Plug-ins → OJI
Keywords: crash
QA Contact: bmartin → dsirnapalli
(Assignee)

Comment 3

16 years ago
I can login to chat room but chatroom page will switch to another page because
firewall (maybe), no crash happen. please try the latest jre (jre1.4.2-beta)
(Reporter)

Comment 4

16 years ago
the latest JDK (which includes the JRE) is instaled (1.4.1.something).

The plugin DOES apper in about:plugins

there is no libjavaplugin_oji.so file, only libjavaplugin.so

Comment 5

16 years ago
libjavaplugin_oji.so should be linking to something like
/usr/java/j2re1.4.1_02/plugin/i386/ns610/libjavaplugin_oji.so

Comment 6

15 years ago
WFM. mozilla 1.6 + jre 1.4.2_02.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.