odd navigation with automatic line breaks

RESOLVED WORKSFORME

Status

()

Core
Editor
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Rune Maagensen, Assigned: Joe Francis)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030422
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030422

When navigating in both composer and mail/news composer, default Windows
behaviour is not followed. Whenever you are at the end of a line and UP or DOWN
arrowkeys are used the cursor often jumpes a line. It doesn't matter whether it
is an automatic linebreak (soft because the input field is narrow), or a hard
line break.
(A line is) jumped if the cursor is more to the right than there are characters
in the line you want to go to.

ex: if the cursor is within the brackets the line with "line break" above is
reached, other wise the line starting with "is an automatic..." is reached.

Reproducible: Always

Steps to Reproduce:
1. HOME
2. END
3. DOWN
4. UP
5. END
6. END
7.-> 17. DOWN
18. UP

The numbers refer to the key hit. Ex destination 1. is reached after HOME is
hit, 2. after END is hit
Actual Results:  
1This is a damn long line with at lot of characters in it.2
There are absolutely no manual line breaks in this lin4e5
and all the numbers refer to where the cursor is.[CR]3
[CR]6
[CR]
[CR]7
[CR]
This 8is a short line[CR]
This i9s a short line[CR]
This i10s a short line[CR]
This i11s a short line[CR]
This i12s a short line[CR]
This i13s a short line[CR]
[CR]
This i14s a damn long line with at lot of characters in it. There are absolutely
no man15ual line breaks in this line and all the numbers refer to where the
cursor1618 is.[CR]
[CR]
[CR]17


Expected Results:  
As you can se somehow a line is "jumped" all the time. This should not be.

The bug started happening after some nightly approx a week ago april 20th or so.
This behaviour is not present in 1.4a or 1.3
(Reporter)

Comment 1

15 years ago
installed latest nightly, and now it works, sorry for the trouble.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
no patch = not fixed
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.