Download Manager does not restart where let off when with out of disk spcae error

VERIFIED DUPLICATE of bug 69938

Status

SeaMonkey
Download & File Handling
--
critical
VERIFIED DUPLICATE of bug 69938
15 years ago
13 years ago

People

(Reporter: david, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401

When downloading a *.iso file (550MB) with download manager and out of disk
space error caused it to fail on near completion. Cleared space on partition in
error expecting to restart. where left off however, had to restart form the
beginning again.

Although the final target partiton had enough disk space (5GB), download Manager
wants to create 2 temporary files under the Windows users profile in Win2k.
These are %userprofile%\local Settings\temp and %userprofile%\Application
data\Mozilla\...\...slt\cache both the same size as the current downloaded status.



Reproducible: Always

Steps to Reproduce:
1. Win2k box with C: drive 1GB free space D: drive 5GB free space.
2. User temp and mozilla cache folders located under Windows user profile on C:
drive.
3. Download file approx 550MB choosing folder on D: drive as target folder



Actual Results:  
Download fails with 'out of disk space' error message with 50MB of download to
go. Unable to restart after clearing down disk space on affected partition.

Expected Results:  
1. You should be able to restart where left off - the temp files are still there!
2. Temp file should be placed in a designated download folder chosen by the user
3. No need to have 2 temp copies of file in cache and in user temp directory
> 1. You should be able to restart where left off - the temp files are still 
> there!

This is a duplicate of an existing bug report.

> 2. Temp file should be placed in a designated download folder chosen by the
> user

This is a duplicate of another existing bug report.

> 3. No need to have 2 temp copies of file in cache and in user temp directory

And this is a duplicate of a third one.

Someone please find one of those three bugs and mark this duplicate.
Whiteboard: DUPEME

Comment 2

15 years ago
Reporter: One bug per report, please.  (after checking that it doesn't already
exist)

*** This bug has been marked as a duplicate of 69938 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.