Special Folder Icon is not applied to imap "Sent" folder, etc

RESOLVED DUPLICATE of bug 45395

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 45395
15 years ago
14 years ago

People

(Reporter: Roland Stuehmer, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.4a) Gecko/20030401

Hi every one!

I created folders 'Sent', 'Templates', and 'Drafts' in my "INBOX." on an IMAP
server. These folders are recognised by Mozilla Mail and utilized as expected
(sent mail stored in 'Sent', etc) but are just shown like any usual folder
although there are special icons that ought to be used.
However when I go to the account preferences "Copies and Folders" and specify
"My Imap Account" -> "Sent" as a sent-mail-folder the desired icon is used in
the Mail main window like expected from the start and the string "Sent" is
localised and the folder is shown at the top of the list among "Templates" and
"Drafts" which I also had to configure like 'Sent' just described.
Could you make folder name localisation and recognition by a special icon a
default for all folders "INBOX.Sent", "INBOX.Templats" and "INBOX.Drafts"
without having users to tweak "Preferences" -> "Copies and Folders"?

This is just a cosmetic bug but since the 'Sent' folder is used as expected it
should also be *displayed* as expected out-of-the box (I assume). :)

Regards, Roland.

Reproducible: Always

Steps to Reproduce:
1. Create an Imap folder "Sent" under "Inbox" ('INBOX.Sent') if there is none.

Actual Results:  
'INBOX.Sent' is used as expected but shown like any standard folder.

Expected Results:  
Instead it should be listed at the top, its name be localised and its special
icon shown without having to trick "Preferences".

Comment 1

15 years ago
Please confirm, I have verified this with 1.4 and 1.5b under Cyrus IMAPd. The
issue appears to be with the IMAP namespace being "INBOX.", and mozilla still
looking for the Sent folder in the server root, instead of prepending the IMAP
namespace.

As a result, the Sent box also displays the From: header instead of the To:
header in the summary, making it infuriating to work on anything.

The workaround the initial reporter suggested does the trick, but shouldn't be
required.

Comment 2

14 years ago
The Cyrus server issue is bug 27002 (see in particular bug 27002 comment 106).

*** This bug has been marked as a duplicate of 45395 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.