Closed Bug 203582 Opened 18 years ago Closed 18 years ago

It would be indeed nice, if Mozilla would not implement the feature with context-menu blocking, used on site paranoid web-sites.

Categories

(Core :: DOM: Events, enhancement)

enhancement
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 86193

People

(Reporter: cnst+bmo, Assigned: saari)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.3) Gecko/20030312

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html 
     PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html>
  <head>
    <title></title>
    <script type="application/x-javascript">
	document.oncontextmenu=new Function("alert('Function Disabled!'); return false;")
    </script>

  </head>
  <body>
    <h1>Test page. Try to get the context-menu (right-mouse-click).</h1>
    <p>It would be indeed nice, if Mozilla would not implement the feature with
mouse blocking, used on site paranoid web-sites.</p>
  </body>
</html>


Reproducible: Always

Steps to Reproduce:
1. Create a file with the contents described above.
2. Open that file. 
3. Right-click in the opened window. 
Actual Results:  
One can see the message, that the function is disabled. 

Expected Results:  
Context menu appears.
I think, it is a good idea to have an option in the user-preferences, in the
area 'Advanced' --- 'Scripts & Plugins', for this feature to be allowed/disallowed. 
Summary: It would bIt would be indeed nice, if Mozilla would not implement the feature with context-menu blocking, used on site paranoid web-sites. → It would be indeed nice, if Mozilla would not implement the feature with context-menu blocking, used on site paranoid web-sites.

*** This bug has been marked as a duplicate of 86193 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.