Closed Bug 203638 Opened 18 years ago Closed 15 years ago

Calendar doesn't send mail when using "Mail selected event..."

Categories

(Calendar :: General, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 237148

People

(Reporter: sharman.chris, Assigned: mostafah)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

can't accept outlook mail of calendar events directly into my calendar.
can't send events to other attendees by mail at all.

Reproducible: Always

Steps to Reproduce:
A: accepting mailed events.
1. Have an outlook user set up a meeting including you.
2. Have him mail it.
3. No way to 'accept' or 'reject' the appointment, except manually create a
calendar event & manually reply.
B. mailing calendar events
1. add calendar event
2. select it
3. file > mail selected event (apparently does nothing)

Actual Results:  
A (accepting) - have to do it all manually.
B (mailing) - nothing - no mail generated.

Expected Results:  
A (accepting) - 'event' type mails should offer accept/reject options, which add
the event to the calendar (or not) & begin an appropriate reply.
B (mailing) - moz should send mail, compliant to any actual or de facto standards.
I believe that replies (accept/reject) are also processable.
*** Bug 204611 has been marked as a duplicate of this bug. ***
I would find also usefull if also task could be emailed to other person, who after
receiving the mail could 'accept' the task and it would be added to his/her
calendar task list. In a perfect situation after she/he will mark as
completed/delete the task I would receive the email.
Status: UNCONFIRMED → NEW
Ever confirmed: true
New contact from mikep@oeone.com to mostafah@oeone.com
Filter on string OttawaMBA to get rid of these messages. 
Sorry for the spam.
Assignee: mikep → mostafah
This bug sounds like it's a bug of a current functionality in "File -> Mail
Selected Event" (of which I'm not intimately familar).
The "I wish it could do this" part is a dupe of bug 59630

The "It doesn't mail when I tell it to" is a bug.
Changing summary to reflect bug scope and setting severity to normal.

Reporter, does this bug still exist using the latest builds? I can't seem to
reproduce it.
Severity: enhancement → normal
Summary: enhancement: can moz mail/calendar send/accept calendar events in an outlook-compatible format → Calendar doesn't send mail when using "Mail selected event..."
I observed this same bug in the 2004-12-27 builds of Sunbird for Windows and
Macintosh. Nothing seems to be happening when I select an event and tell the
program to "Mail Selected Events". I get the same lack of result by
right-clicking and doing it through the contextual menu.
(In reply to comment #7)
> I observed this same bug in the 2004-12-27 builds of Sunbird for Windows and
> Macintosh. Nothing seems to be happening when I select an event and tell the
> program to "Mail Selected Events". I get the same lack of result by
> right-clicking and doing it through the contextual menu.

Yeah, Sunbird doesn't mail at all. We need to #ifdef MOZ_SUNBIRD disable the
mail items.
QA Contact: gurganbl → general

*** This bug has been marked as a duplicate of 237148 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.