Document background color rendered instead of <div> background color

RESOLVED INVALID

Status

()

Core
Layout: Floats
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Michael Ward, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401

The text on this page should be rendered black on white. Mozilla 1.4 (and 1.3)
renders it black on blue (linux and windows 2000). IE renders it as intended (or
at least as I mean to intend it :) ) It appears that the when the "logo" <div>
is closed, Mozilla is using the document's style settings instead of the
containing "box" <div> style settings as specified in the linked style sheet.

Reproducible: Always

Steps to Reproduce:
Simply open www.tcsl.org/index.html in Mozilla 1.4
Actual Results:  
The page renders with a blue background where a white background is intended.

Expected Results:  
The <body> background is blue as specified by the linked style sheet. However,
there is "box" <div> that changes the background color to white. The "logo"
<div> is contained within the "box" <div>. The background color is rendered
correctly in the "logo" <div> but not in the text that follows the "logo" <div>
(and is still contained in the "box" <div>).

The page has been verified HTML 4.01 strict by the W3C.ORG validator.
I have not verified the style sheet.
I have seen this bug on more than one computer (linux, windows 2000, windows xp).

Comment 1

15 years ago
Has something to do with the application of float.  If I take the float off
either .column1 or .column2, the background renders white as expected.

-->Layout/Floats
Component: Browser-General → Layout: Floats

Comment 2

15 years ago
Forgot to assign to component owner.
Assignee: asa → float
QA Contact: asa → ian
The floats do not increase the size of the parent <div> and thus overflow it. 
IE has a bug -- it will increase the height of position:relative divs to contain
the floats in them.  Which is what's happening on this page.

We're rendering the <div> background inside the div, correctly.  But most of the
text is simply outside the <div>.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

15 years ago
I would have to agree since the <div> themselves do not have an intrinsic 
height. Thanks... 
You need to log in before you can comment on or make changes to this bug.