Table cell data shifts out of table on indent

RESOLVED FIXED in mozilla1.5alpha

Status

()

Core
Editor
P1
major
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: rubydoo123, Assigned: glazou)

Tracking

({regression})

Trunk
mozilla1.5alpha
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2] editorbase+)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
Tested using a build from 2003042808 on win2K

1. open composer
2. insert a table (4x4)
3. toggle to HTML Source (it's faster this way) and remove cellpadding,
cellspacing, and style attributes; leave the border attribute
4. toggle back to Normal mode and select the upper left cell, enter the following:
test[shift+enter]test. Enter some bogus text in a couple other cells.
5. set the caret after the first 'test' in the upper left cell and select the
indent button.

Actual results: the word is pulled out of the table cell and inserted above the
table.

Expected: the content of the cell to be indented

Will attach a before and after test case
(Reporter)

Comment 1

15 years ago
Created attachment 121950 [details]
table before the indent selection
(Reporter)

Comment 2

15 years ago
Created attachment 121952 [details]
table after the indent selection

Comment 3

15 years ago
-->core
confirmed on mac
Assignee: composer → jfrancis
Component: Editor: Composer → Editor: Core
Keywords: nsbeta1, regression
OS: Windows 2000 → All
QA Contact: petersen → sairuh
Hardware: PC → All
Whiteboard: editorbase

Comment 4

15 years ago
adt: nsbeta1+/adt2
Keywords: nsbeta1 → nsbeta1+
Whiteboard: editorbase → [adt2] editorbase
editorbase+. It is only present in CSS editing mode.
-> Daniel
Assignee: jfrancis → glazman
Whiteboard: [adt2] editorbase → [adt2] editorbase+
(Assignee)

Comment 6

15 years ago
confirmed, taking.
Severity: normal → major
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla1.5alpha
(Assignee)

Comment 7

15 years ago
Hmmm.... This is VERY weird and seems related to range promotion or
GetNodesForOperation. Still investigating.
(Assignee)

Comment 8

15 years ago
Eheh, found the problem. My fault.
(Assignee)

Comment 9

15 years ago
Created attachment 125072 [details] [diff] [review]
trivial fix
(Assignee)

Updated

15 years ago
Attachment #125072 - Flags: superreview?(peterv)
Attachment #125072 - Flags: review?(kaie)

Comment 10

15 years ago
Comment on attachment 125072 [details] [diff] [review]
trivial fix

I don't yet +fully* understand all the context code, but it seems to be
reasonable based on explanations Daniel gave me on IRC. What convinced me most
is that function WillHTMLIndent contains the same check, that this patch adds
to WillCSSIndent.

r=kaie
Attachment #125072 - Flags: review?(kaie) → review+
Attachment #125072 - Flags: superreview?(peterv) → superreview+
(Assignee)

Comment 11

15 years ago
checked in, trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.