crash in (new XPathEvaluator).createExpression("foo", someResolver)

RESOLVED DUPLICATE of bug 203384

Status

()

--
critical
RESOLVED DUPLICATE of bug 203384
16 years ago
16 years ago

People

(Reporter: axel, Assigned: axel)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
This is a regression from the html-xpath landing.
A XPathEvaluator which was created with new does not have a mDocument, default
casesensitivity to false.
Patch coming up.
(Assignee)

Comment 1

16 years ago
Created attachment 121993 [details] [diff] [review]
default casesensitivity to false if there is no mDocument

I checked this after do_QueryReferent to make sure that this returns something
non-null as well.
(Assignee)

Comment 2

16 years ago
Trying to get this into 1.4b.
This is a lowrisk fix to a regression. The crasher appears when somebody tries
to create a XPath expression from a js-created XPathEvaluator and not from a 
HTML or XMLDocument. Which is perfectly legal and has some good usecases, like
reusing one XPathExpression on more than one document.
The fix is a null-check with the right default value, +5/-1 lines to 
extensions/transformiix/source/xpath/nsXPathEvaluator.cpp
Status: NEW → ASSIGNED
Flags: blocking1.4b?

*** This bug has been marked as a duplicate of 203384 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Flags: blocking1.4b?
You need to log in before you can comment on or make changes to this bug.