Mozilla ignores <td bordercolor="#color1"> if <table border="1" bordercolor="#color0> is set

RESOLVED INVALID

Status

()

RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: bernhard.strobl, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

left column should have bordercolor white (border should not be seen because
background is also white), right column should have bordercolor black, but as
described above mozilla ignores the <td bordercolor="#color"> an only interprets
the <table bordercolor="#color">, i tried the site with internet explorer, and
it works..

Reproducible: Always

Steps to Reproduce:
1.only write a html source with <table bordercolor=#color> and a <td
bordercolor=#color1> and open the site in mozilla
2.
3.

Actual Results:  
all columns have one bordercolor

Expected Results:  
every column should have a different bordercolor

Comment 1

16 years ago
It's not valid HTML :
http://validator.w3.org/check?uri=http%3A%2F%2F80.108.54.158%2Fmozilla%2F&charset=iso-8859-1+%28Western+Europe%29&doctype=HTML+4.01+Transitional
See the spec : http://www.w3.org/TR/html401/struct/tables.html

Correct HTML would be :
<td style="border:1px solid black;">bla</td>
<td style="border:1px solid white;">bla1</td>

Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.