microsoft.com - Submit button does nothing

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
4 years ago

People

(Reporter: mike, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3) Gecko/20030312

The page listed has some rather strange code for doing a form. Clicking the
Submit ubtton should display results next to each question. With Mozilla it does
nothing. The feature works in both Safari and IE under MacOS X.

Reproducible: Always

Steps to Reproduce:
The page has bogus JS (document.styleSheets[4].rules instead of
document.styleSheets[4].cssRules) that throws an exception on that button click.
 IE implements the non-standard "rules" property; looks like Safari follows
suit.  Mozilla implements what the spec says ("cssRules").
Assignee: asa → susiew
Status: UNCONFIRMED → NEW
Component: Browser-General → US General
Ever confirmed: true
OS: MacOS X → All
Product: Browser → Tech Evangelism
QA Contact: asa → zach
Hardware: Macintosh → All
Version: Trunk → unspecified

Comment 2

16 years ago
-> evang500
Keywords: evang500

Comment 3

16 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us

Updated

16 years ago
Summary: Submit button does nothing → microsoft.com - Submit button does nothing

Updated

15 years ago
Blocks: 114158

Comment 4

15 years ago
URL is not showing a survey anymore (redirects to the product site), any new URL ?

Comment 5

15 years ago
re Olivier's comment... ditto. wfm.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.