http://esims.cuny.edu/bb works in Windows, not in Linux

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: Steve Brown, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030429
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030429

When I click on the link http://esims.cuny.edu/bb (in Linux) I get a "404 Not
Found" page that says "The requested URL
/webapp/esimsprod_app/jsps/browserError.html was not found on this server." 
Between clicking on the link and getting the error page the browser seems to be
trying to redirect me to another URL
(http://esims.cuny.edu/webapp/esimsprod_app/NotLoggedInServlet?CurrentCommand=CollegeProcess&CollegeCode=BB)

Reproducible: Always

Steps to Reproduce:
1. Attempt to go to URL http://esims.cuny.edu/bb
2.
3.

Actual Results:  
"404 Not Found" error page.

Expected Results:  
Load page to log in to class registration system.
The page does browser-sniffing and redirects all non-Mac and non-Windows
browsers to an error page... too bad the error page returns a 404 from the
server because they didn't even bother to set it up.

Invalid; you may want to contact SUNY and let them know that their registration
system is not usable....

Here is the relevant JS, just in case:

var HTML_file = "jsps/browserError.html";	//The redirect file name
var isOK = false;		        //If TRUE then the browser is supported

function checkBrowser()  			//Kinda like a main function
{
doLogic();
if (!isOK) forwardPage();
}

//-  -  -  -  -  -  -  -  -  -  -  -  -  -  -  -  -  -  -  -  -  -
function doLogic()				//The brains of the script
{
// * TEST OF WINDOWS *
if (navigator.userAgent.indexOf("Win") != -1)
	{				
	if (navigator.appName.indexOf("Microsoft")!= -1) 	// * TEST IF IE *
		{	
		if ((parseFloat(navigator.appVersion)) < legal_IE_Win_ver)
			{
			alert ("Upgrade Explorer on your Windows System");
			}
		else isOK=true;
		}
	else if (navigator.appName.indexOf("Netscape") != -1)	// * TEST IF NS *
		{
		if ((parseFloat(navigator.appVersion)) < legal_NS_Win_ver)
			{
			alert ("Upgrade Netscape on your Windows System");
			}
		else isOK=true;
		}
	else									// * TEST IF OTHER *
		{
		alert ("You are using an unsupported browser");
		}	
	}


// * TEST OF MAC *
else if (navigator.userAgent.indexOf("Mac") != -1)
	{				
	if (navigator.appName.indexOf("Microsoft")!= -1) 	// * TEST IF IE *
		{	
		if ((parseFloat(navigator.appVersion)) < legal_IE_Mac_ver)
			{
			alert ("Upgrade IE on your Macintosh System");
			}
		else isOK=true;
		}
	else if (navigator.appName.indexOf("Netscape") != -1)	// * TEST IF NS *
		{
		if ((parseFloat(navigator.appVersion)) < legal_NS_Mac_ver)
			{
			alert ("Upgrade Netscape on your Macintosh System");
			}
		else isOK=true;
		}
	else									// * TEST IF OTHER *
		{
		alert ("You are using an unsupported browser");
		}	
	}
else 
    {
//      isOK=true;
    }
}
//-  -  -  -  -  -  -  -  -  -  -  -  -  -  -  -  -  -  -  -  -  -
function forwardPage()		//Forwards the browser to a new link.
{
window.location=HTML_file;
}

Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.