showattachment.cgi does not return filename

VERIFIED DUPLICATE of bug 63601

Status

()

Bugzilla
Attachments & Requests
P3
normal
VERIFIED DUPLICATE of bug 63601
18 years ago
5 years ago

People

(Reporter: Jason Bennett, Assigned: justdave)

Tracking

Details

(Whiteboard: 2.16)

Attachments

(1 attachment)

Description

18 years ago
When attempting to view or download an attachment, showattachment.cgi does not
return a filename, and instead returns its own name. This complicates matters
inordinantly when trying to save an attachment to disk, as you have no idea what
sort of file you are downloading, or what it should be called.

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 1

18 years ago
Created attachment 5028 [details] [diff] [review]
Patch to return filename with attachment

Comment 2

18 years ago
The submitted patch uses an HTTP 1.1 header that Netscape and IE implement to
return the filename with the download. This does not affect text attachments,
however, and their name is still a cgi string.

Comment 3

18 years ago
Regarding "Remove any path information stored in the database"
in the attachment of 2000-02-07,
the regexp   /[^\\]+$/  assumes Windows pathnames.
To handle both Windows and Unix pathnames, try  m{[^/\\]+$} .

Comment 4

18 years ago
References of possible interest:

ftp://ftp.isi.edu/in-notes/rfc2616.txt, section 19.5.1
http://andrew2.andrew.cmu.edu/rfc/rfc1806.html
bug 6519
bug 27248

Comment 5

18 years ago
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
Status: ASSIGNED → NEW

Updated

18 years ago
Status: NEW → ASSIGNED
This bug has a patch on it waiting to get checked in...

Ah, but the patch is incomplete - assumes it's running on Windows.  but it's a 
three character change to get it running on both Windows and Linux and the change 
is described in an earlier comment here.

Updated

18 years ago
Keywords: patch
*** Bug 43286 has been marked as a duplicate of this bug. ***
Point of interest....   according to bug 6519, this functionality used to be in 
Bugzilla, and was removed on purpose because it broke the XML filetype.

What I would suggest here is that if this is put in, that it be conditional, and 
only add the name parameter if the file is known to be binary (since it's ignored 
on text, and breaks XML)

Comment 10

18 years ago
will look to evaluate
Assignee: tara → cyeh
Status: ASSIGNED → NEW
Whiteboard: 2.14

Updated

17 years ago
Whiteboard: 2.14 → 2.16

Comment 11

17 years ago
Adding default QA contact to all open Webtools/Bugzilla bugs lacking one.
Sorry for the spam.
QA Contact: matty
moving to real milestones...
Target Milestone: --- → Bugzilla 2.16

Comment 13

17 years ago
There is another bug about this subject which also has a patch attached, but
it looks more elaborated to me (and is in diff -u format), so I'm marking this
as a duplicate.

*** This bug has been marked as a duplicate of 63601 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verif. duplicate of 63601
Status: RESOLVED → VERIFIED
moving all closed Bugzilla bugs to the new Bugzilla product.
This batch is DUPLICATE/INVALID/WORKSFORME/WONTFIX
reassigning to default owner and QA in case of the bug being reopened.
Clearing milestones, since we really shouldn't have them on these types of
resolutions.  Sorry for the spam everyone...
Assignee: Chris.Yeh → justdave
Status: VERIFIED → NEW
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Target Milestone: Bugzilla 2.16 → ---
Version: other → unspecified

Comment 16

17 years ago
Verification got lost.
Status: RESOLVED → VERIFIED

Updated

16 years ago
Component: Bugzilla-General → attachment and request management
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.