Trunk crash [@ nsAccessibleTreeWalker::GetFullTreeParentNode]

RESOLVED FIXED

Status

()

Core
Disability Access APIs
--
critical
RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: jay, Assigned: Aaron Leventhal)

Tracking

({crash, qawanted, topcrash})

Trunk
x86
Windows XP
crash, qawanted, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

15 years ago
There have been quite a few crashes on the MozillaTrunk lately with this stack
signature.  Not sure if I picked the right component, but here are a few sets of
crashes from the latest Talkback data:

Rank    StackSignature    Count  

13   nsAccessibleTreeWalker::GetFullTreeParentNode   19 

 
 	Source File :
c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibleTreeWalker.cpp line : 99
 
====================================================================================================
     Count   Offset    Real Signature
[ 5   nsAccessibleTreeWalker::GetFullTreeParentNode 19078d9c -
nsAccessibleTreeWalker::GetFullTreeParentNode ]
[ 1   nsAccessibleTreeWalker::GetFullTreeParentNode fcc74424 -
nsAccessibleTreeWalker::GetFullTreeParentNode ]
 
     Crash date range: 2003-04-24 to 2003-04-28
     Min/Max Seconds since last crash: 14 - 9654
     Min/Max Runtime: 32 - 14850
 
     Count   Platform List 
     6   Windows NT 5.0 build 2195
 
     Count   Build Id List 
     3   2003042412
     3   2003042308
 
     No of Unique Users         3
 
 Stack trace(Frame) 

	 nsAccessibleTreeWalker::GetFullTreeParentNode
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibleTreeWalker.cpp 
line 99] 
	 nsAccessibleTreeWalker::GetSiblings
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibleTreeWalker.cpp 
line 127] 
	 nsAccessibleTreeWalker::GetNextSibling
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibleTreeWalker.cpp 
line 196] 
	 nsAccessible::GetAccNextSibling
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessible.cpp  line 245] 
	 nsHTMLComboboxAccessible::Init
[c:/builds/seamonkey/mozilla/accessible/src/html/nsHTMLSelectAccessible.cpp 
line 839] 
	 nsAccessibilityService::GetAccessible
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibilityService.cpp 
line 1661] 
	 gklayout.dll + 0x212a58 (0x616f2a58)  
	 nsHTMLFieldSetElement::AddRef  
	 0xd5cde928   
 
     (19576688)	URL: www.start.de
     (19576688)	Comments: dropdown select
     (19576426)	URL: www.start.de
     (19576426)	Comments: open dropdown on the left side
     (19576423)	URL: www.start.de
 
====================================================================================================
     Count   Offset    Real Signature
[ 3   nsAccessibleTreeWalker::GetFullTreeParentNode ae166f2c -
nsAccessibleTreeWalker::GetFullTreeParentNode ]
 
     Crash date range: 2003-04-21 to 2003-04-21
     Min/Max Seconds since last crash: 46028 - 46028
     Min/Max Runtime: 166266 - 166266
 
     Count   Platform List 
     3   Windows NT 5.1 build 2600
 
     Count   Build Id List 
     3   2003041904
 
     No of Unique Users         1
 
 Stack trace(Frame) 

	 nsAccessibleTreeWalker::GetFullTreeParentNode
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibleTreeWalker.cpp 
line 99] 
	 nsAccessibleTreeWalker::GetSiblings
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibleTreeWalker.cpp 
line 127] 
	 nsAccessibleTreeWalker::GetNextSibling
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibleTreeWalker.cpp 
line 196] 
	 nsAccessible::GetAccNextSibling
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessible.cpp  line 245] 
	 nsHTMLComboboxAccessible::Init
[c:/builds/seamonkey/mozilla/accessible/src/html/nsHTMLSelectAccessible.cpp 
line 839] 
	 nsAccessibilityService::GetAccessible
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibilityService.cpp 
line 1658] 
	 nsAccessibilityService::GetAccessibleInShell
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibilityService.cpp 
line 1494] 
	 nsRootAccessible::HandleEvent
[c:/builds/seamonkey/mozilla/accessible/src/base/nsRootAccessible.cpp  line 301] 
	 nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp  line
1192] 
	 nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp  line
2193] 
	 nsXULDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULDocument.cpp  line 1278] 
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3289] 
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3282] 
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3282] 
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3282] 
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3282] 
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3282] 
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3282] 
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3282] 
	 nsXULElement::HandleChromeEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 4447] 
	 GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp  line 794] 
	 nsDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsDocument.cpp  line 3620] 
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1888] 
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881] 
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881] 
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881] 
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881] 
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881] 
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881] 
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881] 
	 nsHTMLFormElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLFormElement.cpp 
line 736] 
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881] 
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881] 
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881] 
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881] 
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881] 
	 nsHTMLSelectElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLSelectElement.cpp 
line 1955] 
	 PresShell::HandleDOMEventWithTarget
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6393] 
	 nsComboboxControlFrame::ShowPopup
[c:/builds/seamonkey/mozilla/layout/html/forms/src/nsComboboxControlFrame.cpp 
line 608] 
	 nsComboboxControlFrame::ShowList
[c:/builds/seamonkey/mozilla/layout/html/forms/src/nsComboboxControlFrame.cpp 
line 634] 
	 nsComboboxControlFrame::ToggleList
[c:/builds/seamonkey/mozilla/layout/html/forms/src/nsComboboxControlFrame.cpp 
line 1870] 
	 nsComboboxControlFrame::ShowDropDown
[c:/builds/seamonkey/mozilla/layout/html/forms/src/nsComboboxControlFrame.cpp 
line 1833] 
	 nsListControlFrame::MouseDown
[c:/builds/seamonkey/mozilla/layout/html/forms/src/nsListControlFrame.cpp  line
3040] 
	 nsListEventListener::MouseDown
[c:/builds/seamonkey/mozilla/layout/html/forms/src/nsListControlFrame.cpp  line
3755] 
	 nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp  line
1282] 
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1929] 
	 nsHTMLSelectElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLSelectElement.cpp 
line 1955] 
	 PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6329] 
	 PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6273] 
	 nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp  line 2299] 
	 nsView::HandleEvent	[c:/builds/seamonkey/mozilla/view/src/nsView.cpp  line 309] 
	 nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp  line 2035] 
	 HandleEvent	[c:/builds/seamonkey/mozilla/view/src/nsView.cpp  line 83] 
	 nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1163] 
	 nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1180] 
	 nsWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 5462] 
	 ChildWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 5717] 
	 nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 4210] 
	 nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1447] 
	 USER32.dll + 0x27b17 (0x77d67b17)  
	 USER32.dll + 0x2cdce (0x77d6cdce)  
	 USER32.dll + 0x4435 (0x77d44435)  
	 USER32.dll + 0x9611 (0x77d49611)  
	 nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp  line 479]  
 
 
====================================================================================================
     Count   Offset    Real Signature
[ 3   nsAccessibleTreeWalker::GetFullTreeParentNode 5b6b7838 -
nsAccessibleTreeWalker::GetFullTreeParentNode ]
 
     Crash date range: 2003-04-22 to 2003-04-22
     Min/Max Seconds since last crash: 13 - 44
     Min/Max Runtime: 11867 - 507270
 
     Count   Platform List 
     3   Windows NT 5.0 build 2195
 
     Count   Build Id List 
     3   2003042208
 
     No of Unique Users         1
 
 Stack trace(Frame) 

	 nsAccessibleTreeWalker::GetFullTreeParentNode
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibleTreeWalker.cpp 
line 99] 
	 nsAccessibleTreeWalker::GetSiblings
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibleTreeWalker.cpp 
line 127] 
	 nsAccessibleTreeWalker::GetNextSibling
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibleTreeWalker.cpp 
line 196] 
	 nsAccessible::GetAccNextSibling
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessible.cpp  line 245] 
	 nsHTMLComboboxAccessible::Init
[c:/builds/seamonkey/mozilla/accessible/src/html/nsHTMLSelectAccessible.cpp 
line 839] 
	 nsAccessibilityService::GetAccessible
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibilityService.cpp 
line 1661] 
	 gklayout.dll + 0x213b28 (0x616c3b28)  
	 nsHTMLFormElement::AddRef  
	 0xd523e928   
 
 
====================================================================================================
     Count   Offset    Real Signature
[ 3   nsAccessibleTreeWalker::GetFullTreeParentNode 4c292694 -
nsAccessibleTreeWalker::GetFullTreeParentNode ]
 
     Crash date range: 2003-04-27 to 2003-04-28
     Min/Max Seconds since last crash: 56 - 1393
     Min/Max Runtime: 56 - 1886
 
     Count   Platform List 
     3   Windows NT 5.0 build 2195
 
     Count   Build Id List 
     2   2003042708
     1   2003042608
 
     No of Unique Users         2
 
 Stack trace(Frame) 

	 nsAccessibleTreeWalker::GetFullTreeParentNode
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibleTreeWalker.cpp 
line 99] 
	 nsAccessibleTreeWalker::GetSiblings
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibleTreeWalker.cpp 
line 127] 
	 nsAccessibleTreeWalker::GetNextSibling
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibleTreeWalker.cpp 
line 196] 
	 nsAccessible::GetAccNextSibling
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessible.cpp  line 245] 
	 nsHTMLComboboxAccessible::Init
[c:/builds/seamonkey/mozilla/accessible/src/html/nsHTMLSelectAccessible.cpp 
line 839] 
	 nsAccessibilityService::GetAccessible
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibilityService.cpp 
line 1661] 
	 gklayout.dll + 0x212a48 (0x616d2a48)  
	 nsHTMLFieldSetElement::AddRef  
	 0xd516e928   
 
     (19578195)	URL: www.start.de
     (19578063)	URL: www.start.de
     (19578063)	Comments: use of dropdown field before site is fully loaded
form controls are _way_ up on that stack...
Assignee: form → aaronl
Component: Layout: Form Controls → Accessibility APIs
QA Contact: desale → dsirnapalli
(Assignee)

Comment 2

15 years ago
I already looked at all of the accessibility related talkback crashes in recent
builds, including this one which I was able to duplicate on my machine. The fix
is in bug 203774.

*** This bug has been marked as a duplicate of 203774 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

15 years ago
Making this bug dependant on bug 203774.
Status: RESOLVED → REOPENED
Depends on: 203774
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

15 years ago
Reopened bug so we can track this topcrash.  I will mark this fixed once we
verify this crash is gone (after the checkin for bug 203774). 
(Assignee)

Comment 5

14 years ago
This was fixed a long time ago.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → FIXED
Crash Signature: [@ nsAccessibleTreeWalker::GetFullTreeParentNode]
You need to log in before you can comment on or make changes to this bug.