Autoscroll "sticks" if a dialog appears while autoscrolling

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
15 years ago
11 years ago

People

(Reporter: Ken Beal, Unassigned)

Tracking

(Blocks: 1 bug, {testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

When using autoscroll, if a cookie popup happens (from a middle-click opening a
URL in another tab), the autoscroll "sticks" at its speed and you have to
dismiss the cookie window before regaining control of autoscroll.

Reproducible: Always

Steps to Reproduce:
1. Open Slashdot or other news site with multiple links on the front page.
2. Open a link to a site you haven't been to before (using middle-click, which
(when configured properly) opens the link in a new tab and leaves you in the
original tab).
3. Immediately middle-click on whitespace, activating the autoscroll
functionality (this is installed separately, see http://autoscroll.mozdev.org/
), and move the cursor down (or up) so that the window starts scrolling.
4. When the new site attempts to set a cookie (and you've configured it to ask
you prior to setting cookies), a window pops up asking whether to allow the cookie.
5. Moving the mouse up or down has no effect on autoscroll; it continues
scrolling at the same speed in the direction it was scrolling prior to the popup
appearing.
Actual Results:  
Moving the mouse up or down has no effect on autoscroll; it continues scrolling
at the same speed in the direction it was scrolling prior to the popup appearing.

Expected Results:  
I expect the popup to temporarily disable the autoscroll, so no scrolling occurs
while focus cannot be obtained.  Or, it could just permanently disable
autoscroll and I would have to middle-click again to activate it after I dismiss
the popup.

Or, even better, the cookie popup would be "just another window" and would not
be modal (?) -- I would still be able to focus on the tab I was on, and change
to other tabs, and use Mozilla normally except there would be a separate window
with the cookie question in it.
Dunno if this is the same bug - it seems like it should be, so to reduce
duplicates, here goes.

If autoscroll is active and you click on a link that opens in a new tab (with
Open Links in Background unchecked in Options), you are switched to the new tab,
but autoscroll is still active in the original tab.  When you finish in the new
tab and switch back to the original, autoscroll suddenly reappears.  I would
expect autoscroll would be canceled by a new window/tab/popup being opened. 
Current behavior (although it makes sense) is a little disconcerting the first
time around.

I'm using the default Windows Firebird nightly from September 1.

Comment 2

15 years ago
This bug isn't applicable to the Mozilla suite, since it does not support
autoscroll natively, however I have verified that the bug does exist in
Firebird's autoscroll feature. I couldn't find an obvious dupe, so I'm
reassigning this bug to Firebird.
Assignee: asa → blake
Status: UNCONFIRMED → NEW
Component: Browser-General → General
Ever confirmed: true
Product: Browser → Firebird
Version: Trunk → unspecified

Comment 3

14 years ago
Created attachment 136209 [details]
testcase

Steps to reproduce:
1. Load this testcase.
2. Click the button.
3. Quickly middle-click (but don't hold) to start autoscroll.

Result: Scrolling continues while the dialog is active (at a constant rate). 
After you dismiss the dialog, you have control of the scrolling speed instead.

Expect: Scrolling should pause or stop while the dialog is active.

Updated

14 years ago
Keywords: testcase
Summary: When using autoscroll, if a cookie popup happens (from a middle-click opening a URL in another tab), the autoscroll "sticks" at its speed and you have to dismiss the cookie window before regaining control of autoscroll → Autoscroll "sticks" if a dialog appears while autoscrolling

Comment 4

14 years ago
Autoscroll also "sticks" if you alt-tab to another window.

Comment 5

14 years ago
*** Bug 230276 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Blocks: 212273
Created attachment 190003 [details] [diff] [review]
patch

This sort of works, but has problems. It responds to all kind of blur
notifications, probably. It should only listen to a blur event that happens on
the document.
OS: Windows 2000 → All
Hardware: PC → All
Assignee: bross2 → nobody
QA Contact: asa → general
This was fixed by the patch in bug 240363.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Depends on: 240363
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.