Browser crashes on <select name="lightm_db" onchange="this.form.submit()"> code

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: t.rother, Unassigned)

Tracking

({crash, stackwanted})

Trunk
x86
Windows 2000
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: TB19642238E, URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030429
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030429

If you click on the pulldown menu inside phpMyADMIN application (a web interface
for mysql), Mozilla crashes. 

Reproducible: Always

Steps to Reproduce:
1. use an installation of phpMyADMIN (this is mostly internal used, so I can not
give you a public URL for this)
2. on the startup page, a list of available databases ist shown on the left frame
3. click on the pulldown window.

Actual Results:  
Browser crashes. See talkback issue TB19642238E

Expected Results:  
Pulldown is shown

This is a persistent issue for the nigthlies since 1 or 2 weeks. I would think
is has to to with the "this.form.submit()" event. See page code enclosed.
(Reporter)

Comment 1

16 years ago
Created attachment 122079 [details]
page code - html output

Code for navigation page with  <select name="lightm_db"
onchange="this.form.submit()"> section which may be the reason for the crash.
See www.phpmyadmin.net for more details.
(Reporter)

Updated

16 years ago
Attachment #122079 - Attachment description: phpmyadmin page code → page code - html output

Comment 2

16 years ago
-> DOM Level 0
Assignee: rogerl → dom_bugs
Component: JavaScript Engine → DOM Level 0
Keywords: crash, stackwanted
QA Contact: pschwartau → ashishbhatt
Whiteboard: TB19642238E
(Reporter)

Comment 3

16 years ago
Created attachment 122080 [details]
page code - php input

This is the original php code from which the html output is generated
(Reporter)

Comment 4

16 years ago
As of build 20030502, this seems to be fixed now. But I still see a crash on a
js-enhanced page. Will file that separately ...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.