Folders in Bookmarks Toolbar stay Expanded if menu was closed with right-click operation on content

VERIFIED DUPLICATE of bug 203899

Status

()

Firefox
Toolbars and Customization
VERIFIED DUPLICATE of bug 203899
15 years ago
11 years ago

People

(Reporter: Atsushi Nakagawa, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030429 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030429 Mozilla Firebird/0.6

If the dropdown menu to folder in the Bookmarks Toolbar is closed as a result of
a right-click operation on one of the bookmarks contained in that folder, the
folder, although the corresponding menu is no longer displayed, will remain in
an "Expanded" internal state.

[internal state = the state of an arbitary code layer beneath the GUI.]

An "Expanded" state describes the state that is the opposite to the "Collapsed"
state.

In the expanded state, the folder button in the Bookmarks Toolbar responds to
mouse-overs by altering its edges to make a button appear "depressed".  Upon
right-clicking directly on the folder name, a context-menu is presented with the
first item being the word "Collapse" in bold.  In this state, key presses are
stolen by an invisible focus.

Reproducible: Always

Steps to Reproduce:
1. Start the browser [in a new profile].
2. Right-click on the Bookmarks Toolbar and select "New Folder".
3. Click OK to close the Properties window that popped up.
4. Fill the folder with at least one bookmark [or folder*].
5. Left-click on the newly created folder name to expand its menu.
(Note: "Click" as opposed to "Click & Hold".)
6. Right-click on any bookmark in the expanded drop down menu.
7. Click "Copy".  (It doesn't matter which operation in the menu is performed here.)

*Works with folder as content instead of bookmark but harder to reproduce.
Actual Results:  
The folder is still "Expanded" even though the drop down menu is no longer
displayed.

Expected Results:  
Stay in sync with GUI.
(Reporter)

Comment 1

15 years ago
Apparent "Connection Timeout", as reported by this browser, caused this 
duplicate.


*** This bug has been marked as a duplicate of 203899 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v.
Status: RESOLVED → VERIFIED

Comment 3

14 years ago
Taking QA Contact
QA Contact: asa → bugzilla

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.