Window size should depend on screen_resolution

VERIFIED FIXED

Status

SeaMonkey
Preferences
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Richard Zach, Assigned: Chris McAfee)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
The window size of the prefs dialog (as well as lots of other dimensions
throughout Mozilla) should be calculated from the broswer.screen_resolution
preference.  In Linux, when you set that pref to 120 or 140, the window is too
small to display the dialog correctly.

Build 1999.11.30.08 Linux.
(Reporter)

Comment 1

18 years ago
Created attachment 3135 [details]
screen shot of prefs window at screen_resolution 140

Updated

18 years ago
Assignee: shuang → german

Comment 2

18 years ago
there a couple of other related issues to pref window sizes. reassign it to
german for decision on size, and platform.

Updated

18 years ago
Assignee: german → don
Target Milestone: M14

Comment 3

18 years ago
I am not even sure hwo we can tackle this from the perspective of CSS using
screen res, but in theory using absolute measures for CSS font sizes like 3.5mm
should give you this for free? does this work properly in Gecko? re-assigning to
Don to see what can in theory be done about this. Past dogfood!

Updated

18 years ago
Target Milestone: M14 → M15

Comment 4

18 years ago
Past beta too.

Comment 5

18 years ago
i just wrote some expermental js functions to size the browser based on the js
screen object and am calling it from the Startup() function.

One thing i noticed was that in order for these functions to work, i had to
explicitly remove the width="640" height="480" from my <window tag in the xul
file.

otherwise, it prevents any dynamic initial sizing of the loading browser window.
it bacicly locks down the size so you can't change it at all.
(I am on unix.)
I even tried to resize from calling setAttribute().
nochange until i removed the width and height.


I thought i would point this out.

pete

Comment 6

18 years ago
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences

Comment 7

18 years ago
Move to M16 for now ...
Target Milestone: M15 → M16

Updated

18 years ago
Target Milestone: M16 → M18

Comment 8

18 years ago
Move to M21 target milestone.
Target Milestone: M18 → M21

Comment 9

18 years ago
this is a stale bug. it has not been touched in more 30 days.it no longer
reperducible and i suggest it be marked WFM.
(Reporter)

Comment 10

18 years ago
On my machine, the symptoms of this bug haven't changed.
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy

Comment 12

17 years ago
*** Bug 69150 has been marked as a duplicate of this bug. ***
->mcafee.
Assignee: vishy → mcafee
QA Contact: cpratt → sairuh
This bug also exists elsewhere in the DB (I know I reported it at least once). 
Nominating for mozilla 1.0 - this looks very unprofessional, and prefs is
usually one of the first things someone sees of a new browser.  Also, I think
this is OS All; I think I saw something similar on Win32



From the bug recently marked as a dup:

When you load a brand-new installation of the browser and hit Preferences,
the dialog box pops up far too small for all the UI elements.  They get
cut off at the right and bottom.  And the box has no resize handles.

You can resize it if your window manager has a forcible resize command, and
it then remembers the size it was set to, but this will be extremely
confusing and irritating to new users (who may have no idea that there is
any such thing as a forcible resize).

I suspect this is a general problem with XPToolkit dialog boxes; the "open
file" dialog box comes up with the right hand side of the list cut off, too. 
They should take their size from the size of the elements they contain.

Keywords: mozilla1.0, polish
OS: Linux → All

Comment 15

17 years ago
I have also run into this problem on Win 98 (First Edition), Mozilla Build
2001050515.  
I set my message box text (using the Display Control Panel) to use the Georgia
font at 11 point size prior to installing Mozilla.  My resolution is 1024x768. 
When I went to the Preferences-Font screen, I found the Set Resolution area to
be truncated, similar to what is shown in the initial bug report. 

Comment 16

17 years ago
*** Bug 80535 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
bug 21810 was marked fixed today. Doesn't that also fix this one?
(Assignee)

Comment 18

17 years ago
ben fixed the pref window to respect font size
back in mid-may sometime.  marking fixed, over
to him if we need to reopen.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
okay, vrfy.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.