fieldset with height=100% drops bottom border.

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
15 years ago
8 years ago

People

(Reporter: Ian, Unassigned)

Tracking

(Blocks: 1 bug, {testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

A field set with a height seems to be dropping the bottom border. 

Reproducible: Always

Steps to Reproduce:
1. Click on attachement to follow.

Actual Results:  
Bottom border is dropped.

Expected Results:  
I would expect to see the bottom border.

Seems like there is a misscalculation on the height of the object.

I tested this with todays nightly build and it still occurs.
(Reporter)

Comment 1

15 years ago
Created attachment 122099 [details]
Testcase to show bug

Updated

15 years ago
Component: Browser-General → Layout
Keywords: testcase
.
Assignee: asa → form
Status: UNCONFIRMED → NEW
Component: Layout → Layout: Form Controls
Ever confirmed: true
OS: Windows 2000 → All
QA Contact: asa → desale
Hardware: PC → All

Comment 3

15 years ago
Bug 176237 also deals with inline elements missing borders, is that possibly 
related?  The only difference (it seems) is that the elements in that bug are 
relative positioned.
Note that if I reset height to 120% and then back to 100% the border shows....

Updated

13 years ago
Blocks: 252406
Assignee: layout.form-controls → nobody
QA Contact: desale → layout.form-controls
Seems to be worksfrome now.  Is this still reproducible?
And more precisely, this was just a bug with table cells not supporting overflow, looks like...
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.