Content of a pop-up window not shown. I suspect it's a JavaScript interpreting issue.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
4 years ago

People

(Reporter: parencibia, Unassigned)

Tracking

({qawanted, testcase})

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030428 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030428 Mozilla Firebird/0.6

In the page http://www.abc.es/ a small question appears when entering the site.
After answering "Yes", "Ok" or "Sí" (whatever applies), a pop up window appers
showing headlines information.

Using Mozilla, the information is not being properly decodified so JavaScript
code is displayed instead of the content. You can compare the behaviour of this
page with Internet Explorer to see the desired result.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.abc.es
2. Answer "Ok", "Yes" or "Sí" to the question that appears in a small question
box. (Question text: "¿Quieres ver las últimas noticias?")
---
Note: First time you enter the site, you may be asked for your location. I
cannot reproduce it now, but you may skip this question and go to the important one.

Actual Results:  
A pop up window appears with JavaScript code

Expected Results:  
A list of last-minute headlines should appear.
This is not likely to be a JS engine bug.  Over to browser-general; please do
not confirm unless you can explain WHY the site sends us bogus info (cookie bug?
 Bad browser sniffing on the site?  etc).
Assignee: rogerl → asa
Component: JavaScript Engine → Browser-General
Keywords: qawanted
QA Contact: pschwartau → asa

Comment 2

16 years ago
This is definitely a document.write() bug, but probably a dupe.  When I have 
javascript enabled I get this:

function status2() 
{
document.write('QueryString - did - Es vacio o invalido..');
}

When js is disabled I see the page just fine.  There's a lot of 
document.write'n material here, so that's my assumption.  Unfortunately I can't 
download the necessary external script files through the Address bar, and I 
don't have time to try harder :)

Updated

16 years ago
Keywords: testcase

Comment 3

15 years ago
-Tech Evangelism
See also bug 134247
Assignee: asa → spanish
Component: Browser-General → Spanish
Product: Browser → Tech Evangelism
QA Contact: asa → spanish
Version: Trunk → unspecified
They no longer have popups, marking as WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.