enhancement: Be able to edit and change IMAP messages

RESOLVED DUPLICATE of bug 203913

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED DUPLICATE of bug 203913
15 years ago
14 years ago

People

(Reporter: Adrian Marsh, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030430
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030430

I'm a crossuser of Outlook and Mozilla. One nice ability in Outlook is to be
able to edit a recieved email, and then save it back to the IMAP server. This
allows me to delete massive (mostly useless) attachments, whilst retaining the
text content of the message.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
delete attachments is bug 2920

Comment 2

15 years ago
Yes, this is an excellent feature that I would like to see in Mozilla mail.

However, I want to expand it a little. I subscribe to a large number of email
lists that are pretty active, and I like to archive messages. A very large
percentage of messages contain extraneous text (not attachments!) that wastes a
lot of disk space. Many posters evidently don't care if their messages include
10 previous messages. I would really like to be able to remove the extra stuff
to save my disk space.

Another problem with these messages is that they use HTML formatting, which
wastes even more space. Sometimes it makes sense to have it, and sometimes it
doesn't. And some (many) people send both plain and HTML text. I would like this
RFE to include being able to remove all rich formatting from the message and
leave plain text only.

I would like to suggest that summary of this bug be changed to "Be able to edit
and change incoming messages" and that the request include modifying local and
IMAP messages and removal of rich formatting from the messages. 

As has been mentioned in comment #1, removal of attachments in a message in any
folder has been requested in another bug report.

I think that OS field should be changed to All.
(Reporter)

Updated

15 years ago
OS: Windows 2000 → All

Comment 3

15 years ago
This is probably a dup of bug 203913 (and, as mention in comment 1, bug 2920).

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 203913 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.