When javascript status bar changing is disabled, status bar doesn't show url when mouseovering link that attempts to change the status bar text

VERIFIED DUPLICATE of bug 40838

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 40838
15 years ago
15 years ago

People

(Reporter: Peter, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030429 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030429 Mozilla Firebird/0.6

When the "Advanced Javascript Options" > "Change status bar text" option is NOT
checked, the status bar will not display the URL to a link the mouse is hovering
over, if the link would normally use the mouseover event to change the status bar.

Reproducible: Always

Steps to Reproduce:
1. Gott http://www.google.com/search?q=lego
2. Mouseover the "Lego" link in the ad under sponsored link on the right-hand side

Please note that this will work with any Google query that produces an ad under
sponsored links on the right-hand side.
Actual Results:  
The status bar continues to say "Done", instead of showing the link URL

Expected Results:  
The default action when mouseovering a link is to show the URL that the link
points to. If you have told the browser not to allow javascript to change the
status bar, it should still display the URL in the status bar, instead of not
changing it at all.

Comment 1

15 years ago
CONFIRMED.  Note that right-clicking the link will cause the correct URL to show
up in the status bar at that point.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

15 years ago
Yes, right-clicking on the link does show the URL in the window. However, as
often as not, there is javascript to activate the link for a mouseclick as well,
and as far as I know javascript's mouseclick is not discriminate as to which
button was in fact clicked, which kind of defeats the ability to determine what
URL the link is to before you go there.

Comment 3

15 years ago
Created attachment 122186 [details]
testcase

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 40838 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.