Page loads repeatedly on some secure sites, making form input impossible

VERIFIED DUPLICATE of bug 178595

Status

()

Firefox
General
--
major
VERIFIED DUPLICATE of bug 178595
15 years ago
15 years ago

People

(Reporter: Lonnon Foster, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030429 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030429 Mozilla Firebird/0.6

Firebird tries to load this page over and over again, at less than one second
intervals. This makes it impossible to enter form data, because the form is
cleared with each page load. The throbber and the stop button pretty much go
berserk while this is happening, flashing rapidly between active and inactive.

Reproducible: Always

Steps to Reproduce:
1. Open https://onlinebanking-nw.bankofamerica.com/ in Firebird.
Actual Results:  
Firebird tries to load and reload the page, more than once per second.

Expected Results:  
The page should load once.

The same effect happens on another secure page. Steps to repro:

1. Open http://www.alaskausa.org/ in Firebird.

Unlike the bankofamerica.com site, the alaskausa.org site stops trying to load
and reload after a minute or so.

I'm guessing this might have something to do with secure sites, or possibly just
some odd scripting those sites use as part of their login process.

This bug does not occur in the Mozilla 2003042908 nightly.

Comment 1

15 years ago
WFM for both sides using Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b)
Gecko/20030429 Mozilla Firebird/0.6
Will give it a try on a XP-box to see if I can repro the problem there...

Comment 2

15 years ago
Tested both sides using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b)
Gecko/20030429 Mozilla Firebird/0.6 and they still work for me!

Lonnon: is this a fresh installation using a new profile? If not, can you give
it a try with a new installation in a different directory and using a new profile? 
Do you have any extensions installed?
(Reporter)

Comment 3

15 years ago
I didn't have any extensions installed, but it's a moot point. I just
performed a fresh install of this morning's daily, and it works
perfectly. I don't have the older version around to try installing it
again to see if the problem still exists in the older version, but
that's academic. The current daily build doesn't have the bug. Whatever changes
were made over the last couple of days have inadvertently fixed this one, or
both of my computers were under the effects of Martian bogon rays.
(Reporter)

Comment 4

15 years ago
Okay, I just reproduced it, but it's probably not Firebird's fault. The bug
occurs when the Orbit 3+1 theme
(http://downloads.mozdev.org/themes/themes/morbit-1_3-20030316.jar) is installed
and active. When the default Phoenix theme is active, the bug doesn't occur.
I'll post a bug to the theme's owner.
(Reporter)

Comment 5

15 years ago
It turns out this is a known bug; Chris Neale, the author of Orbit 3+1, posted a
userChrome.css workaround (http://themes.mozdev.org/themes/orbit.html#198)
yesterday (2003/05/01):

#status-bar {
min-height: 23px !important;
}

With this in my userChrome.css, the repeated page reload no longer happens. I
hadn't thought to connect the page reload with resizing of the status bar.

Comment 6

15 years ago

*** This bug has been marked as a duplicate of 178595 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 7

15 years ago
Well I already contacted Chris, the developer of the Orbit theme, to figure out,
whether this is really an Orbit-bug and how this problem should be handled.
According to him this is a site problem because pages, which shows these
problems, do not distinguish between Mozilla and NS 4 - so from my point of
view, this should be filed as a Tech Evangelism bug.

=> reopening bug #178595 and moving over to tech evangelism?

Comment 8

15 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.