CPU cycles consumed when animated graphics exist on page even when hidden from view

VERIFIED DUPLICATE of bug 120154

Status

()

Firefox
General
--
enhancement
VERIFIED DUPLICATE of bug 120154
15 years ago
14 years ago

People

(Reporter: Anwar Rohillah, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

There are some banner ads that make use of animation.  These animations 
consume CPU resources.  When the ad is not displayed, such as when the window 
is minimized or blocked from view, the CPU usage remains the same.

Reproducible: Always

Steps to Reproduce:
1.Go to a website with an animated graphic
2.Minimize window
3.Watch CPU utilization

Actual Results:  
CPU utilization remains heavy

Expected Results:  
Mozilla should free the CPU resource when it is not needed.

Comment 1

15 years ago
Reporter: could you try recent nightly or Mozilla?

Comment 3

15 years ago
We have many bugs related to CPU utilization of animated GIFs in general - some
of them also mention this problem besides the original problem, but bug #120154
seems to only deal with the CPU utilization during minimized / "in other tab"-stuff.

=> resolving "duplicate"

*** This bug has been marked as a duplicate of 120154 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 5

14 years ago
*** Bug 248743 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.