If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Should display error/warning when create same server from the account wizard

VERIFIED FIXED in M18

Status

MailNews Core
Backend
P2
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: Karen Huang, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][PDTP2])

(Reporter)

Description

18 years ago
Used WinNT 11-30-12-M12 & Linux 11-30-08-M12 commercila build,

Tried to Create the 2nd news server by using the same new server as the existing
one, should display error/warning to describe the new server already existed!

1) Be sure there was a news server there.
2) Tried to recreate the same news server as step (1) by using account wizard.
3) Actual Results: The news server which is same as existing one had been
created without error and also overwrite the existing one.

Expected results: Should display error/warning when created new server which
already existed, shouldn't overwrite the existing one.

Updated

18 years ago
Assignee: phil → alecf

Comment 1

18 years ago
I think it's legitimate to have more than one identity for the same server, but
I'm not sure if creating a new account is the right way to do that. Reassigning
to alecf.

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 2

18 years ago
yep, though this bug is legit - it should at least warn the user.

Updated

18 years ago
Target Milestone: M13

Comment 3

18 years ago
Overwriting the existing account is a beta stopper

Updated

18 years ago
Priority: P3 → P2

Updated

18 years ago
Priority: P2 → P3

Updated

18 years ago
Target Milestone: M13 → M17

Updated

18 years ago
QA Contact: lchiang → huang

Updated

18 years ago
Target Milestone: M17 → M20

Comment 4

18 years ago
*** Bug 41162 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
this bug applies to all server types
Summary: Should display error/warning when create same new news server from the account wizard → Should display error/warning when create same server from the account wizard

Comment 6

18 years ago
I think this should be a polish bug.  Nominate for nsbeta3.  Moving target 
milestone to M18 to correspond to the nomination.
Keywords: nsbeta3
Target Milestone: M20 → M18

Comment 7

17 years ago
Adding mail4 triage nomination keyword.
Keywords: mail4

Comment 8

17 years ago
Is this similar to http://bugzilla.mozilla.org/show_bug.cgi?id=29579?

+ per mail triage
Whiteboard: [nsbeta3+]
(Reporter)

Comment 9

17 years ago
No. I think they are different.
bug 29579 is : created two different AOL accounts in one profile, this bug is 
creating exactly the same account again....Ccing nbaca.

Comment 10

17 years ago
I agree with Karen, they are different.

Updated

17 years ago
Priority: P3 → P1

Comment 11

17 years ago
to pdt: P1 because the existing account could be overwritten - data loss

Comment 12

17 years ago
PDT marking P2 and leaving [PDTP2]. Might be P1 if local data store was lost.
Priority: P1 → P2
Whiteboard: [nsbeta3+] → [nsbeta3+][PDTP2]
taking this bug from alec.

Assignee: alecf → sspitzer
Status: ASSIGNED → NEW
Whiteboard: [nsbeta3+][PDTP2] → [nsbeta3+][PDTP2] working on this now (9-5-00)
accepting.
Status: NEW → ASSIGNED
fix checked in.

I check if the proposed account exists when you hit "next" on the server page of
the new account wizard.  (the proposed account is the triplet
{username,hostname,type}).

if that account already exists, you don't go on to the next page of the new
account wizard.

Instead, an alert with the following text pops up:  "An account of this type
with the same username and hostname already exists.  Go back and change it or
hit cancel."

(adding jglick to the cc list so she can supply a better alert message.)

marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta3+][PDTP2] working on this now (9-5-00) → [nsbeta3+][PDTP2]
re-open.  I made it work properly for news, but not for mail servers.
I'll mark this fixed when I finish it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
ok, now it's fixed.

we do the right thing for all the server types (nntp and pop/imap)
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

17 years ago
Verified on WinNT 09-06-08-M18 commercial build IMAP, POP and NNTP accounts
Verified on Linux 09-06-08-M18 commercial build IMAP, POP and NNTP accounts
Verified on Mac 09-06-04-M18 commercial build IMAP, POP and NNTP accounts

An alert/warning "An account of this type with the same username and hostname 
already exists.  Go back and change it or hit cancel." is displaying now. 

jglick can still supply a better alert message if she wants. 
Marking as verifiied!!
Status: RESOLVED → VERIFIED

Comment 19

17 years ago
cc'ing Robin Foster for wording issue.

Comment 20

17 years ago
Seth, can you re-word the error message as follows? Thanks.

A mail or newsgroup account with the same user name and server name already
exists. Click Back and enter a different server name, or click Cancel.
the alert text has been updated to robinf's suggested text.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.