javascript urls are not working

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: bob, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020605
Build Identifier: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020605

I have a frameset page with two frames that are built dynamically with
javascript urls.  When I hit enter to retrieve the page the browser never
returns, the status line displays "transferring data from sitename".  

Reproducible: Always

Steps to Reproduce:
Save this html to a file and retrieve it to reproduce error:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<HTML><HEAD><SCRIPT type="text/javascript">top.defaultStatus = '';
top.status = 'The server has begun sending the tabular result of your query';
</SCRIPT></HEAD>
<FRAMESET ROWS="13%,*" BORDER="1" FRAMESPACING="1" FRAMEBORDER="0"
ONLOAD="top.defaultStatus='Done...';">
<FRAME FRAMEBORDER="1" NAME="TOP" SCROLLING="YES"
SRC="javascript:top.defaultStatus='Formatting report headers...';
document.open('text/html');
document.writeln('<HTML><HEAD><SCRIPT>');
document.writeln('</SCRIPT></HEAD>');
document.writeln('<BODY>');
document.writeln('<TABLE BORDER=1 CELLSPACING=0 COLS=7><TR>');
document.writeln('    <TD ALIGN=RIGHT VALIGN=BOTTOM
WIDTH=\'70\'><B>bytes</B></TD>');
document.writeln('    <TD ALIGN=RIGHT VALIGN=BOTTOM WIDTH=\'70\'><B>hits</B></TD>');
document.writeln('    <TD ALIGN=RIGHT VALIGN=BOTTOM WIDTH=\'70\'><B>hits
2xx</B></TD>');
document.writeln('    <TD ALIGN=RIGHT VALIGN=BOTTOM WIDTH=\'70\'><B>hits
3xx</B></TD>');
document.writeln('    <TD ALIGN=RIGHT VALIGN=BOTTOM WIDTH=\'70\'><B>hits
4xx</B></TD>');
document.writeln('    <TD ALIGN=RIGHT VALIGN=BOTTOM WIDTH=\'70\'><B>hits
404</B></TD>');
document.writeln('    <TD ALIGN=RIGHT VALIGN=BOTTOM WIDTH=\'70\'><B>hits
5xx</B></TD>');
document.writeln('</TR>');document.writeln('</TABLE></BODY></HTML>');
document.close();
"><FRAME NAME="BOTTOM" SCROLLING="YES" SRC="javascript:document.open('text/html');
document.writeln('<HTML><HEAD><SCRIPT>');
top.defaultStatus='Formatting report detail...';
document.writeln('</SCRIPT></HEAD>');
document.writeln('<BODY>');
document.writeln('<TABLE BORDER=1 CELLSPACING=0 COLS=7>');
document.writeln('<TR>');
document.writeln('    <TD ALIGN=RIGHT WIDTH=\'70\'>3,860,912,488</TD>');
document.writeln('    <TD ALIGN=RIGHT WIDTH=\'70\'>663,238</TD>');
document.writeln('    <TD ALIGN=RIGHT WIDTH=\'70\'>227,695</TD>');
document.writeln('    <TD ALIGN=RIGHT WIDTH=\'70\'>379,541</TD>');
document.writeln('    <TD ALIGN=RIGHT WIDTH=\'70\'>55,648</TD>');
document.writeln('    <TD ALIGN=RIGHT WIDTH=\'70\'>55,621</TD>');
document.writeln('    <TD ALIGN=RIGHT WIDTH=\'70\'>236</TD>');
document.writeln('</TR>');document.writeln('</TABLE><p>1 rows returned.</p>');
document.writeln('<TABLE BORDER=2 CELLPADDING=10 CELLSPACING=0 WIDTH=100%>');
document.writeln('<CAPTION>Column Name Glossary</CAPTION>');
document.writeln('<TR>');
document.writeln('    <TH ALIGN=LEFT VALIGN=BOTTOM><B>Column</B></TH>');
document.writeln('    <TH ALIGN=LEFT VALIGN=BOTTOM><B>Description</B></TH>');
document.writeln('</TR>');
document.writeln('</TABLE></BODY></HTML>');document.close();"><NOFRAMES>
Actual Results:  
browser never displays page.  displays "transferring data from sitename" in
status bar.

Expected Results:  
display the page

I have found this problem on mozilla 1.3 and 1.4a.  Mozilla 1.0 works ok.

Comment 1

16 years ago
Hi Bob, are you still having problems with recent builds of Mozilla not
displaying the code you included in this bug report? I just tried it on the
20031001 nightly build on Win 2000 and, as far as I can tell, the HTML displayed
fine. Thanks for any additional information.
(Reporter)

Comment 2

16 years ago
I downloaded a Mozilla daily build (1.6.0.2003100804) and the javascript
problems have been fixed.  Thanks for the update and to all who made this work!

Comment 3

16 years ago
Glad to hear it. I'm resolving the bug worksforme, since there isn't a specific
patch for it. Thanks for following up on this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.