image cropped, text overlap - untill reflow




Layout: Tables
15 years ago
9 years ago


(Reporter: R.K.Aa., Unassigned)


({regression, testcase})

regression, testcase
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)




(1 attachment)

1.06 KB, text/html


15 years ago
current cvs, linux but not new - been seeing this a week or more:

Notice what you see of the image in the story.
Notice that text under the image stretch into the main story on the left.

-Now right-click image and "view image"
-Then select the "back" button.
(Or resize text up/down)

Result: Much more of the image becomes visible.
Text gets readable, and it becomes appearant that all along, the image text was
actually running along the full length of the image.

Comment 1

15 years ago
trying tables for component.
Assignee: asa → table
Component: Browser-General → Layout: Tables
QA Contact: asa → madhur

Comment 2

15 years ago
Also Confirming on Windows 2000
OS: Linux → All

Comment 3

15 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030501
I´m using tabbed browsing, opening links in the background.

When I saw an impressive flash movie at the top of the page,
I looked at the source code, found a lot of very special javascript.
There are three coded lines in the HEAD, 
defining a string t=...
and via eval + unescape two vars var f=...+t...
and in the BODY there is checking for Flash6, Win95, Win98, IE, Netscape, 
and calling VBS if assumed valid.

Comment 4

15 years ago
Hermann Schwab: Try a common reload while the tab is NOT in the background.

Comment 5

15 years ago
WFM Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030502
Shockwave Flash

    File name: NPSWF32.dll
    Shockwave Flash 6.0 r79

MIME Type 	Description 	Suffixes 	Enabled
application/x-shockwave-flash 	Macromedia Flash movie 	swf 	Yes
application/futuresplash 	FutureSplash movie 	spl 	Yes

I copied the URL from here, open a new tab, my fourth, and pasted the URL there,
to load in the foreground. All went well. Did some Reloads and Shift-Reloads,
no differences. Windows is Win98 with Servicepack 1 and some MS-supplied patches.

Do you see the flash movie, the landscape passing by as seen from the window of
a train?
Do you have the latest flash plugin installed?
How do you install your mozilla, net-installer, full installer, zip?
I´ve seen flash not working on a page, when I used a zip-version of Mozilla.
Using the exe-installer version, the flash was working.
The difference: the installer registers the flash plugin in the
windows-registry, so scripts can use the plugin.

Comment 6

15 years ago
Flash  6.0 r79 works fine here. Right now I can not reproduce tbe bug. It's the
"train flash" mentioned in comment 5 that is playing. When I saw the bug it was
another flash add there. Whatever the bug is, it's not in Netscape 7.02, which i
then compared against.

As originally indicated I see the layout bug with a trunk CVS build.

WFM, since the offending code seems to be gone
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 7

15 years ago
still there, now seen at
Currently two flash adds there, a top one for SAS and below it one for a James
Bond movie or something.

A reload cures it. A ctrl+reload triggers it again.
Tried an older build - 2003042105, linux - and was unable to see tbe bug there,
regardless of how i reloaded, deleted cache etc.
Resolution: WORKSFORME → ---


15 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 8

15 years ago
WFM using Moz1.5-rc1.
can anyone still reproduce?

Comment 9

15 years ago
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME

Comment 10

15 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031014 Firebird/0.7+

Please REPOPEN, as I can still repro this bug.  Unfortunately, I cannot do so

I've seen it by going back & forward quickly, finishing on the 'problem' page. 
I'm pretty sure that I've also seen it with a reload or shift-reload, but can't
remember exactly.

If the image and image text get displayed _before_ the article text, this bug
seems to happen.

Since the overlap is 80px, I'd say that this html has something to do with it:
<table align=right border=0 width=200 cellpadding=2 cellspacing=0 hspace="5">
		<tr align="right"> 
                <td valign=top><table align=RIGHT width=280 border=0
cellpadding=2 cellspacing=0 hspace=5><tr><td><img
src= width=280 height=189
alt=""  border=0>

Note how the enclosing table has a width of 200, but a cell in that table and
the image in the cell have a width of 280.

If I have time, I'll try to come up with a reduced testcase.


Comment 11

15 years ago
I figured out why I couldn't reproduce this bug consistantly.  The bug only
shows if a reflow occurs at a particular point during the page load.

Using a tip from Hyatt's Safari blog about how to force a reflow, I was able to
create a testcase, to be attached shortly.

Please REOPEN.


Comment 12

15 years ago
Created attachment 133500 [details]

Comment 13

15 years ago
reopen since djk can still repro - perhaps this needs some looking into
Resolution: WORKSFORME → ---

Comment 14

14 years ago
This is a incredibly annoying bug for those of us actually reading,
but no developers seem to have noticed this bug, even though it has a
reproducible test case. A pity.


14 years ago
Keywords: testcase

Comment 15

10 years ago
this is WFM with current trunk

Comment 16

9 years ago
WFM here as well. I think this can be closed now.


9 years ago
Last Resolved: 15 years ago9 years ago
Flags: in-testsuite?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.