task list should retain order when changing, adding or deleting a task

RESOLVED WORKSFORME

Status

Calendar
Tasks
--
minor
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Navid Vahdat, Unassigned)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Anytime a change is done to a task the ordering of the task list is destroyed.

It would be nice to have sorting by multiple criteria (e.g first criteria:
priority, second criteria: due date) or at least stable sorting.

Reproducible: Always

Steps to Reproduce:
Have several tasks of low, high and middle priority.

1. Click "Hide completed Tasks"
2. Sort by priority
3. Mark a task completed

Actual Results:  
The order of the tasks in the task list seems accidental -- not just within the
priorities but completely accidental.

I also get different orders within the priority when I sort by priority
descending, then ascending and again descending.

Comment 1

15 years ago
I can confirm. I do not agree that the order after marking as done is
accidental, it seems to me that the bug is that after you sort according to any
other field than due date, after marking any event as done the sorting goes back
to default due date sorting rule.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
New contact from mikep@oeone.com to mostafah@oeone.com
Filter on string OttawaMBA to get rid of these messages. 
Sorry for the spam.
Assignee: mikep → mostafah

Comment 3

13 years ago
I still have this bug with Sunbird 0.2. I have my tasks ordered by category. If 
I delete any of them the ordering by category is kept, but within that the order 
of tasks changes randomly.

Comment 4

13 years ago
probably due to using the javascript Array.sort method, which is not a stable
sort (Bug 224128).

Comment 5

13 years ago
For me the order of the tasks seems to be always accidental, regardless of
viewability of completed tasks or what I'm actually trying to sort them after.
For example, when I try to sort them after "complete"ness, the uncomplete tasks
are all bunched up in the middle with some completed tasks above and below.
Is this antother bug or does it merely broaden the scope of this one?

Updated

13 years ago
QA Contact: gurganbl → sunbird

Comment 6

12 years ago
I can't reproduce this on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.9a1) Gecko/20051020 Mozilla Sunbird/0.2+

Is anyone else still seing this?

Comment 7

12 years ago
I'm handling this in bug 232202.
Assignee: mostafah → jminta
Depends on: 232202

Updated

12 years ago
Status: NEW → ASSIGNED

Comment 8

11 years ago
bug 232202 has now landed.  this should be fixed in tomorrow's nightly.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Reopening because patch in bug 232202 was backed out and should also fix this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Moving bugs from Joey without a patch back to nobody, since Joey has basically left the project.
Assignee: jminta → nobody
Status: REOPENED → NEW
Component: Sunbird Only → Tasks
OS: Windows 2000 → All
QA Contact: sunbird → tasks
Hardware: PC → All

Updated

10 years ago
Duplicate of this bug: 395005

Comment 12

9 years ago
This bug doesn't apply to Lightning 0.9. Could probably be closed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.