button doesn't get the "disabled" look

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: vedran, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 98
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.4b) Gecko/20030502
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.4b) Gecko/20030502

When submitting messages or loging in in Invision Board (and some others) in IE
or older Mozilla builds, the Submit button would get the disabled look. In
recent builds it doesn't change.

Reproducible: Always

Steps to Reproduce:
1. go to http://forums.invisionpower.com/
2. go to "Log In" page

OR

3. go to test posting messages
4. add reply or create a new thread
5. write something and click "Submit"
Actual Results:  
Button doesn't get "disabled" look-

Expected Results:  
When button is clicked, it should get the "disabled" look.

It doesn't depend on browser theme, WinXP themes or whatever.
It doesn't happen with older builds (I don't know how old precisly, because I
don't have them all archived).
Hm... Why should clicking the button give it the disabled look?  I see no code
on the login page that sets the button to be disabled...
(Reporter)

Comment 2

16 years ago
I don't know if "disabled" would be the exact word.
But button should change for sure, because it worked that way two weeks before
(estimated) and it works that way in IE.
It also doesn't work in YaBBSE anymore (another forum), so I guess it is a
Mozilla bug this time (actually a regression over 1.4a).
Perhaps we are talking about different pages?  I load
http://forums.invisionpower.com/ and click "log in" next to the "Welcome Guest"
text.  That puts me at http://forums.invisionpower.com/index.php?act=Login&CODE=00

There are three buttons on this page ("Log me in" and two "Go!" buttons).  When
I click any of these in a 1.3, 1.4a, or current trunk Linux build they get focus
and switch to having inset borders until I let go.  At that point they go back
to outset borders, while still having focus.  At no point does anything look
disabled.

If we are talking about the same page, please explain clearly the steps to
reproduce.  If we are talking about different pages, please point me to the page
that shows the problem.
(Reporter)

Comment 4

16 years ago
Basically, button should change the way it looks when you click on it.

I am not exactly sure, but it seems to me that something has changed about it in
the lastest nightly. I am going to test it right now.

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.4b) Gecko/2003050610
(Reporter)

Comment 5

16 years ago
Ok, it seems to work the way it's intended now (but something was obviously
changed recently, becuase I tested same page in 1.3 and 1.4b nightly at the same
time). What could have caused it?
Without a reasonably narrow date range for when the problem started happening,
there is no good way to tell (especially given the continuing lack of a clear
problem description -- "should change the way it looks" tells me nothing useful;
an exact description of what should change and how would).

If this is not a bug in current nightlies, please mark worksforme.

Comment 7

16 years ago
This regressed between 2003042808 and 2003043004.
What happens is that on the submit, the values are checked, and then the code does:
document.LOGIN.submit.disabled = true;
return true;

And for some reason the disabled look is now no longer applied.
(Note, I haven't tested in anything newer than 2003043004; if the button is once
more getting the disabled look on the submit (easiest to test with a new
profile, when the actual submit will be interrupted by the password manager),
this should indeed be marked WFM.)
Keywords: regression
OS: Windows 2000 → Windows 98

Comment 8

16 years ago
okay, so I went on to download today's nightly, and whatever it was has indeed
been fixed. (2003050608)
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

16 years ago
Works for me too, I have checked the posting engine - it works all correctly now.

I am glad that it was fixed.

I apologize for not checking it in lastest nightly (20030506) before adding
aditional comments.
(Reporter)

Comment 10

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.