bad phrasing at msgmdn.properties

RESOLVED WONTFIX

Status

--
trivial
RESOLVED WONTFIX
16 years ago
10 years ago

People

(Reporter: tsahi_75, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; he-IL; rv:1.0.2) Gecko/20030208 Netscape/7.02
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; he-IL; rv:1.0.2) Gecko/20030208 Netscape/7.02

at
http://lxr.mozilla.org/mozilla/source/mailnews/extensions/mdn/resources/locale/en-US/msgmdn.properties#43
(if i'm pointing to the right place), it reads:

"The message has been deleted. The person you sent it to may or may not have
seen it. They might undelete it at a later time and read it."

English is not my first language, but i think i know enough to say that 'person'
should be 'persons', because 'have' can't refer to a singular, and there is a
'they' at the beginning of the next sentence.


Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

16 years ago
i think this is a fairly easy one. what would it be, invalid or be fixed in 5
minutes?
(Reporter)

Comment 2

15 years ago
<cough>anyone?</cough>
(Reporter)

Comment 3

15 years ago
another option is:

"The message has been deleted. The person or persons you sent it to may or may
not have seen it. They might undelete it at a later time and read it."

Comment 4

15 years ago
the community on irc.mozilla.org thinks the wording is ok...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

15 years ago
i asked someone who knows English better than me, and she says that you are
right, but the third sentence should be "he/she *may* undelete it...", because
'may' is present tense, and 'might' is past, and you can't use them both at the
same time. also, she agrees with me that 'they' won't work with 'person'. one of
them must change, or replace both with 'one'.

this is not a matter of opinion, it's a matter of syntax rules.
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Return Receipts → MailNews: Backend
QA Contact: grylchan → offline
You need to log in before you can comment on or make changes to this bug.