Save dialog doesn't save when existing file is renamed through file dialog

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: cm, Assigned: asa)

Tracking

({platform-parity})

Trunk
x86
Windows XP
platform-parity

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030503 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030503 Mozilla Firebird/0.6

Save dialog doesn't save when existing file is renamed through file dialog

Reproducible: Always

Steps to Reproduce:
1. Click on file or image to download to your hard drive.
2. If file aready exists (on your hard drive), click on it in the "Save" dialog
window and rename it.
3. Click to save  the internet file.
4. You're warned that the file *still* exists (even though you've just renaimed
it). Click to over-write the file.
5. Download commences, but when finished, the file did NOT download.

Actual Results:  
Read above.

Expected Results:  
If a file already exists, you should be able to re-name it through the save
dialog (which you can).  With the existing file renaimed, Moz should NOT warn
you that the file still exists (because it doesn't, you've just renaimed it).
Expected Results: Moz should save the file, but doesn't (or it's leaving it in
cache somewhere and not copying it over.

This happens with the latest Mozilla and Firebird releases.

Reproducable: Always.
Sounds windows-only, since on the other platforms you cannot rename from the
filepicker.
Keywords: pp

Comment 2

16 years ago
WFM on WinXP and 2003050211
(Assignee)

Comment 3

15 years ago
worksforme with windows Mozilla 2004020308
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.