rendering issues with &# characters above charcter 1423

RESOLVED INVALID

Status

()

Core
Layout: Text
--
minor
RESOLVED INVALID
15 years ago
9 years ago

People

(Reporter: Tig, Assigned: mkaply)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.3) Gecko/20030408
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.3) Gecko/20030408

Mozilla seems to have problems rendering special HTML characters above ֏
The following PHP code is a simple loop that can be used to generate the issue
or you can visit the URL http://lvl.sourceforge.net/misc/characters.php to see
for yourself.

If you make a section over from before 1423 and past 1423, then enable the
right-mouse click context menu, Mozilla (on FreeBSD anyway) seems to have some
issues. It kind of locks up for a while. On WindowsXP this is selection problem
is not present, however the 'View Selection Source' option returns un-expected
results.

Reproducible: Always

Steps to Reproduce:
1. Visit http://lvl.sourceforge.net/misc/characters.php and scroll down until
you see the 1423 entry. The 1423 entry is not correctly displayed. Its should be
[character] &#1424;<br /> 
2. The following PHP code is code used to generate that page;
<html>
<body>
<pre>
<?php

        for ($i=0; $i <=2048; $i++) {
                echo "[&#".$i.";] &amp;#".$i.";<br />\n";
        }
?>
</pre>
</body>
</html>

3. (under FreeBSD) Select a section of the page before and after the 1423 entry
and right mouse click.

4. (under WindowsXP) Select a section of the page before and after the 1423
entry and right mouse click -> View Selection Source. The source is not what is
expected.
Actual Results:  
FreeBSD: A render page with unexpected results and a freeze up for a while.
WindowsXP: The source does not render correctly.

Expected Results:  
The page should have been in the following format;
[char] &#number;<br />
[char] &#number;<br />
[char] &#number;<br />

However the result of;
[&#1423;] &#1423;
[&#1424;] &#1424;

Is a little strange. I'm not sure if this is really a bug however IE (on
WindowsXP) and w3m (version w3m/0.4.1, FreeBSD) have no such issue with the same
page.  


I've flaged the problem as Minor however there is no workaround that I know of.
The "not correctly displayed" thing is due to BiDi reordering, since the char
you're looking at here is a r-to-l char.  So this part is invalid.

I suspect the slowness on selection is due to the very long line of BiDi text....

Please file a separate bug on the "view selection source" issue and cc rbs@maths
on it.
Assignee: jaggernaut → mkaply
Component: String → BiDi Hebrew & Arabic
QA Contact: scc → zach

Comment 2

14 years ago
Marking INVALID as per comment #2.

The slowness of BiDi varies with different platforms. I wouldn't be surprised if
the attachment in Bug 188294 would also take significantly longer to render
under FreeBSD compared to WinXP.

Prog.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

9 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.