Closed Bug 204388 Opened 22 years ago Closed 21 years ago

rename Ctrl+= to Ctrl++

Categories

(SeaMonkey :: Composer, defect)

defect
Not set
trivial

Tracking

(Not tracked)

VERIFIED FIXED
Future

People

(Reporter: Lil46john, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030428 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030428 Mozilla Firebird/0.6

Composer uses Ctrl+= but Browser, Mail uses Ctrl++

I prefer Ctrl+= because I used to go

[Ctrl] plus [Shift] plus [=]

because [shift] plus [=] is +

But Ctrl++ makes sense because the other thing is a - so the opposite should be a +

I would prefer if you made Mail/Browser use Ctrl+= though because of the 
[Shift] plus [=] confusion

This is an old problem I see but reporting now so maybe it's a dupe...


Reproducible: Always

Steps to Reproduce:
1. Go to Composer>Menubar>Format>Size>Larger
2.
3.

Actual Results:  
See Ctrl+= which is less confusing then Ctrl++ but inconsistent with Mail and
Browser

Expected Results:  
Change Mail and Browser to Ctrl+=
or
Change Format>Size>Larger(Ctrl+=) to Format>Size>Larger(Ctrl++)
The + refers to the numeric keypad, NOT to the + on the keyboard. This should be
a dupe of bug 70141.

Actually, both ctrl-+ and ctrl-= do the same thing, otherwise we would force
everyone to use ctrl-shift-= Not

On build 2003050208 on Mac OS X 10.2.5, I can only see Cmd-+ in both the browser
and view-menus (Macs use Cmd, not Ctrl), but no Cmd-=. Since I don't have a
numerci keypad (it's a portable), I can't verify if Cmd-+ works. Are you sure it
works differently in the browser and mailer ?
Attached image comparison
I can't understand your comment. Does this contradict what your saying?
Ah, the font-menu of the composer. But that's a totally different than the
view-menu in browser/mailer ! Ok, I can't find a dupe, although I'm very sure
that it was reported somewhere. 

PS: it was already decided in bug 70141 that the visible shortcurt was ctrl-+,
although ctrl-= should also work (for people without a numeric keypad, or with a
non-QWERTY keyboard). Not everyone has a = key right of the - key.
Why do you say ctrl-+ instead of ctrl++?

Why not ?
I confirm this bug for this changing the CTRL+= to CTRL++
It makes no sense to have different shortcuts !

Status: UNCONFIRMED → NEW
Ever confirmed: true
helpwanted, future
Status: NEW → ASSIGNED
Keywords: helpwanted
Target Milestone: --- → Future
Attached patch Proposed patchSplinter Review
Brings Composer's Font Size menu in line with Browser's Zoom menu.
Attachment #123511 - Flags: superreview?(alecf)
Attachment #123511 - Flags: review?(brade)
Attachment #123511 - Flags: review?(brade) → review+
<brade> fix the whitespace on keybinding2 to align with previous line
Comment on attachment 123511 [details] [diff] [review]
Proposed patch

sr=alecf
Attachment #123511 - Flags: superreview?(alecf) → superreview+
Comment on attachment 123511 [details] [diff] [review]
Proposed patch

This is a low risk patch to add common alternative keys to increase the font
size, as people expect to be able to use the same keys as they do for browser's
zoom function.
Attachment #123511 - Flags: approval1.4?
Comment on attachment 123511 [details] [diff] [review]
Proposed patch

a=asa (on behalf of drivers) for checkin to 1.4.  Please note in your checkin
comment that this impacts L10N
Attachment #123511 - Flags: approval1.4? → approval1.4+
r=bobj for UI change and L10N impact
Whoops, forgot to mark this as fixed, I'm sure I checked it in.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
cleaning up
Status: RESOLVED → VERIFIED
Keywords: helpwanted
Summary: composer uses Ctrl+= but Mail and Browser uses Ctrl++ → rename Ctrl+= to Ctrl++
a=adt Please check into the Mozilla 1.4 branch and add the keyword fixed1.4
Patch was checked in before 1.4 branched but marking fixed1.4 anyway.
Keywords: fixed1.4
Verified in the 2003-06-06-05 Macho and Win32 trunk builds
Keywords: fixed1.4verified1.4
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: