Feature Request: Should be able to compose an [non-]HTML message for a single compose/reply without changing your account preferences.

VERIFIED DUPLICATE of bug 167588

Status

SeaMonkey
MailNews: Message Display
--
enhancement
VERIFIED DUPLICATE of bug 167588
15 years ago
14 years ago

People

(Reporter: Peep Chaintreuil, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

I quite often find myself going into the Mail & Newsgroup Account Settings in
order to temporarily change my "Compose messages in HTML format" check box to
send a single message in HTML (my default is non-HTML) and then setting it back
once the message is started in the desired format. 

It would be nice if there was a way to choose the other format for a single new
message ("compose") or a single reply/reply all message.  Temporarily this could
be done via right click menus for replying to messages and another entry in the
File->New and Message menus, but hopefully, it would end up being drop down from
the icons as well (like the "Get Message" and "Print" icons).

I have no idea how the code is structured for this area, so I don’t really know
how major or minor this request is.  It’s just something I find myself doing
once a week or so, so that I stick embed a picture in an message or because I
want to make sure something formats just right in a no-wrap table…..


Reproducible: Didn't try

Steps to Reproduce:

Comment 1

15 years ago
You can do this easily per message: In the Compose window, click "Options ->
Format -> Rich Text (HTML) Only". That's the best workaround.

Do I understand your request correctly that you want a drop-down menu to the
Compose button?
Shift-click on the compose button will invert the meaning of the HTML mail pref
for that one message.  This has been the case since Netscape 4 days....

There is already a bug on exposing that in the menus.
Whiteboard: DUPEME

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 167588 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Whiteboard: DUPEME

Comment 4

15 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.