Closed Bug 20450 Opened 20 years ago Closed 20 years ago

Keyboard focus not set when entering a new HTML page

Categories

(Core :: XUL, defect, P1)

x86
Other
defect

Tracking

()

VERIFIED DUPLICATE of bug 9701

People

(Reporter: zivc, Assigned: travis)

Details

When the browser displays a new HTML page, it does not set the keyboard focus to
any meaningful location. Thus, use of the keyboard (for example, to scroll up or
down) requires the user to FIRST click on the page and THEN to use navigation
keys. Even keys like ALT (to place the focus in the menu area) do not work.
Assignee: chofmann → don
-> don.  webshell?
Assignee: don → buster
Component: other → Editor
editor, buster
Assignee: buster → hyatt
Component: Editor → XP Toolkit/Widgets
chris, why do you think this has to do with the editor? It seems to be true of
any HTML page, whether it includes a text control or not.  I verified this by
opening sample 0 and sample 1, with sidebar and toolbars closed in the browser
so no text controls existed anywhere in the UI.
I think this is a hyatt/saari focus bug.
This is a dup of a known bug that has floated between joki, myself, pinkerton,
and I believe now rests in Travis' bin.
Is this maybe a dup of 9701?
Assignee: hyatt → travis
la la la
Travis, is this really our bug?  If so, we definitely need to fix it for beta 1.
Priority: P3 → P1
Target Milestone: M14
This bug seems to be a dup of 9701 which I will hopefully fix soon.  Anyway 
marking as a dup.

*** This bug has been marked as a duplicate of 9701 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Marking Verified as a dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.