"Save all files to this folder" does not work as expected

VERIFIED DUPLICATE of bug 192551

Status

()

Toolkit
Downloads API
--
minor
VERIFIED DUPLICATE of bug 192551
15 years ago
10 years ago

People

(Reporter: athakur, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6

The "save all files to this folder" option does not work as expected.  If you
download a file and change the path in the "Save As" dialog, a subsequent
download attempt will also save to the new path and not the path in the "save
all files to this folder" option.  Accessing the preferences after the second
download shows that the option has been changed to the new directory.

Reproducible: Always

Steps to Reproduce:
1. Set the "save all files to this folder" path to "D:\Downloads"
2. Download a nightly from http://ftp.mozilla.org/pub/phoenix/nightly/latest-trunk/
3. In the "save as" dialog that pops up, change the path to "D:\" and save the file
4. Download the file again, the "Save As" dialog initial directory is "D:\", not
"D:\Downloads" as expected
5. Going to preferences shows the preference has been changed to "D:\"

Actual Results:  
Have to manually go back to the desired download directory in the "Save As"
dialog and reset the "save all files..." setting.

Expected Results:  
All download attempts should save to the directory specified in the "save all
files..." options, regardless of where the last download was saved.  The setting
should also not be changed except directly by the user.

This doesn't seem to occur for all types of file downloads.  I.e. "save image
as" doesn't seem to show this behaviour.

Comment 1

15 years ago
http://www.mozillazine.org/forums/viewtopic.php?t=10266

Above link is the thread on the forum.

I experienced this since the nov 5th, 2002 build (first one I used).
Additional problem seems to be that after saving once to another folder, the
radio button 'Ask me where to save every file' gets selected.

Comment 2

15 years ago
*** This bug has been marked as a duplicate of 192551 ***

*** This bug has been marked as a duplicate of 192551 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.