NSS_Shutdown does not clean up resources

RESOLVED INVALID

Status

NSS
Libraries
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: thomask, Assigned: Robert Relyea)

Tracking

3.7.3
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
NSS_Shutdown does not call appropriate PKCS#11 call to
close up sessions and clean up resources.

Comment 1

15 years ago
I seem to recall that NSS_Shutdown does call the
appropriate PKCS#11 call to close up sessions and
clean up resources.  The problem is that some
resources are held in the server-side SSL session
ID cache, and there is no way to free those resource
until NSS 3.7.4 or 3.8 (the new function
SSL_ShutdownServerSessionIDCache).

I will let Bob give the authoritative answer.
Assignee: wtc → relyea

Comment 2

15 years ago
Bug 199082 was the RFE for SSL_ShutdownServerSessionIDCache.
(Reporter)

Comment 3

15 years ago
Want to ask if NSS_Shutdown will call C_Finalize.
(Assignee)

Comment 4

15 years ago
NSS_Shutdown() will call C_Finalize, but only if the application has freed all it's NSS 
resouces associated with the token. You can get an indication of this by checking the 
return code from NSS_Shutdown().

bob
(Assignee)

Comment 5

15 years ago
Shutdown does call the appropriate PKCS #11 calls if the application has freed
all of it's NSS references.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.