Mozilla hangs on this page upon saving complete web page

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: harvested_from_mozilla4, Assigned: bugzilla)

Tracking

({hang})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030502
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030502

Mozilla crashes (locks up) on this page if I do a CTRL-S (Save page As) and then
choose the "save complete web page" option.  From what I can tell, all the
needed files have been downloaded, so the crash appears to happen at the end of
the download phase.  The download manager's dialogue box remains on the screen
at crash time.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
Kevin, when you say Mozilla crashes, do you mean it quits? If it "locks up,"
then you may actually mean that it hangs, instead.

WorksForMe using FizzillaMach/2003-05-01-08-trunk
Summary: Mozilla crashes on this page upon saving complete web page → Mozilla crashes on this page upon saving complete web page
(Reporter)

Comment 2

16 years ago
You're right, I should have said it hangs.  Mozilla does stay up on the screen,
though two of the three times I did it, the download manager dialogue box wasn't
fully drawn when it stopped working.

I saved a dozen or so pages today using that CTRL-S and this is the only one
that gave me a problem.  I'll try it again tomorrow with a new build and see if
it continues.

Comment 3

16 years ago
worksforme with linux trunk 20030305
you might also try a clean profile
Keywords: hang
Summary: Mozilla crashes on this page upon saving complete web page → Mozilla hangs on this page upon saving complete web page
(Reporter)

Comment 4

16 years ago
The same page still causes Mozilla to hang in build 2003050604 on Win2000. 
However, I just tried this same build (2003050604) on a Win98 machine and had no
problem.

What do you mean by a "clean profile?"  I guess that means I need one :)

Comment 5

16 years ago
Works for me with the 2003-05-05-09 trunk build under Win XP. 

Reporter, one way of creating a new profile is to use the Switch Profile feature
(under Tools menu in Mozilla). Clicking on Manage profile button in the Select
User Profile dialog will allow you to create a new profile on the fly. Once a
new profile is established, select it from the list and press use profile.
(Reporter)

Comment 6

16 years ago
Thanks for that profile tip.  Unfortunately, the same behaviour continued with a
new profile.  I also tried it after a fresh system reboot, in case that would
help matters (it didn't).  I guess this is unique to Win2000.

Comment 7

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803
WFM with a Windows 2000 system
Product: Browser → Seamonkey

Comment 8

14 years ago
Also works for me on my XP machine
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041122
(Reporter)

Comment 9

14 years ago
Well, it works here on the reporter's system now too--the one which originally
had the problem, which is now running Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.6b) Gecko/20031208.

Hard to say what that little glitch might have been, but it seems to have
repaired itself.


(In reply to comment #8)
> Also works for me on my XP machine
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041122
thanks for teh response
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.