When using a <FORM ... METHOD=POST>, data from the form is not passed

VERIFIED FIXED in M12

Status

()

defect
P3
critical
VERIFIED FIXED
20 years ago
5 months ago

People

(Reporter: brian, Assigned: pollmann)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

When using a <FORM ... METHOD=POST>, data from the form is not passed to the
next page.  This has been confirmed with two seperate configurations I have
running WIN32.  I haven't yet tested it on the Linux build.

Here's an example, which was run from IIS using ASP to print the passed
variable:

...
<FORM ACTION=test.cgi METHOD=POST>
<INPUT TYPE=text NAME=test>
<INPUT TYPE=submit>
</FORM>
...

TEST.CGI
--------
<HTML>
<BODY>
VARIABLE PASSED IS <% =Request("test") %>
</BODY>
</HTML>


The sample above works fine using IE and Netscape.  Also worth noting, using
METHOD=GET does pass the data correctly.  Only the POST method seems to be
affected.
Assignee: leger → karnaze
Component: Browser-General → Form Submission
POST form submission has been working for a while now.  For example, Bugzilla
uses it.

Your example probably needs to be much more specific and easy to reproduce.
However, I'm changing the component here to Form Submission anyway and
reassigning, since that's where it goes.

Also, you should say what build you're using.  For all I know, you could be
using the Gecko developer preview from a year ago.  (And I'm not sure POST
worked then...)
Sorry about that, I'm running the M10 release.

To reproduce this bug, (under WIN32 build) navigate to ANY page that uses a
<form> tag with the POST method.  After submitting the form, the next page will
not receive any data.  However, to make it easier for you, I set up a specific
test page that you can navigate to.  The URL is http://www.enslain.com/bug1.htm

By the way, POST does work under Linux.  This seems to affect the WIN32 build
only.
Assignee: karnaze → pollmann
Reassigning to Eric.
Status: NEW → ASSIGNED
Target Milestone: M12
Post has been fixed since M10.  I'm betting this bug is fixed in recent builds.

The ASP page for your test case is not working for me.  I'll attach at test case
of my own.
Posted file Working test case
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Yes, this works.  Closing the bug out.
You can try a nightly build if you would like to verify this for yourself.
Thanks!
QA Contact: leger → ckritzer
Updating QA Contact info.
Marking VERIFIED FIXED on:
- MacOS86 2000-01-26-03 Commercial Build
- Linux6 2000-01-25-20 Commercial Build
- Win98 2000-01-25-20 Commercial Build
Status: RESOLVED → VERIFIED
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.