browser spins forever when home directory on nfs mount

VERIFIED DUPLICATE of bug 90682

Status

()

--
blocker
VERIFIED DUPLICATE of bug 90682
16 years ago
12 years ago

People

(Reporter: j-warren, Assigned: ccarlen)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

When a user's home directory is on an nfs mounted device, mozilla will spin
forever and not launch.  While this might not seem like a big issue to those
with local accounts, it does prevent use and adoption of the software by
corporate users who use nfs volumes for home directories.

I'm priortizing this as a "blocker," although it has apparently been around for
several versions - I'm honestly a bit baffled that it hasn't been prioritized
more highly given the large userbase that is excluded from using the package by
the bug.

Reproducible: Always

Steps to Reproduce:
1.  Create a user whose home directory is on an nfs mount.
2.  Login as that user
3.  Launch mozilla

Actual Results:  
The browser never appears.  A ps -u reveals that run_mozilla.sh and md5sum are
spinning.

Expected Results:  
Launched as normal, and read user preferences as normal from the nfs mounted home.
(Reporter)

Comment 1

16 years ago
oops...this is a dupe of 196487

*** This bug has been marked as a duplicate of 196487 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

16 years ago
Flags: blocking1.4?
(Assignee)

Comment 2

16 years ago
Not a dup. Bug 196487 is specific to OS X and there's a well known reason why
that doesn't work with NFS home dirs. It's because OS X is using fctl for
profile  locking and that doesn't work with many NFS servers. Linux does not use
that type of locking and instead uses one which is supposed to work with any NFS
server. AFAIK, this is the first report of this on Linux. 
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

16 years ago
Nope.

*** This bug has been marked as a duplicate of 90682 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Flags: blocking1.4?
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.