Firebird doesn't open default mail application when clicking on <a href='mailto:....

VERIFIED INVALID

Status

()

VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: dev, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6

When clicking on a mailto anchor, Firebird doesn't open my default mail
application, but opens Outlook Express... wich is definitely not my default
mail, cause Outlook prompt me to make it default...

Reproducible: Always

Steps to Reproduce:
1. Write a page containing:
      <a href='mailto:whatever@thing.com'>Link to mailbox</a>
2. Open in firebird
3. Click on the link
Actual Results:  
Outlook Express opens.
My default registered mail application is Mozilla.

Expected Results:  
Open Mozilla Mail.
Mozilla Browser 1.3 does it correctly.

Am I doing something wrong?

Thank you.

Comment 1

16 years ago
Olivier, can you please check the following key in your registry:

My Computer\HKEY_CLASSES_ROOT\mailto\shell\open\command

I expect the executable of Outlook Express to be entered there? 
(Reporter)

Comment 2

16 years ago
Indeed...

So now I've got questions:
   (i) Why does Mozilla/Browser 1.3 override this reg key and does open the
'real' "Default Mail Application"?
   (ii) Why firebird doesn't?
   (iii) What is the correct behavior?
   (iv) Why Mozilla/Mail 1.3, when setting it as the default mail application,
doesn't change that reg key?

Thank you.
Best regards.

Comment 3

16 years ago
Concerning (1): Mozilla seems to ignore the reg-key implying that one also wants
to use Mozilla Mail if one uses Mozilla as browser - but that's just a guess
from my side! See also bug #56478, where also some discussions concerning
mailto-Links and the handling within Mozilla going on

Concerning (2): Firebird behaves correctly ( from my point of view)

Concerning (3): see (2)

Concerning (4): sorry - can't tell you that. Perhaps some guys more experienced
on this may help you out, e.g. using the forums @MozillaZine.org?

Nevertheless I'd suggest resolving this bug as "invalid". It's not "WFM" as the
described behaviour of Phoenix is not a bug at all!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 4

16 years ago
Just found another one: bug #196720 seems to be more related to your questions -
perhaps you might want to join this bug?
(Reporter)

Comment 5

16 years ago
// Concerning (2): Firebird behaves correctly ( from my point of view)

Ok... By the way IE behaves same...

// Nevertheless I'd suggest resolving this bug as "invalid". It's not "WFM" as
the described behaviour of Phoenix is not a bug at all!

Ok... I do agree.

// Just found another one: bug #196720

Indeed. In fact, I thought Firebird had a bug, and it appears to be a
Mozilla/Mail bug.

Anyway, there are two things wrong here, that don't concern Firebird:
(i) Mozilla/Mail doesn't register correctly when setting it as the default mail
(cause it 'forgot' that reg key).
(ii) Mozilla/Browser doesn't behave correctly to determine wich mail client
should be used.

So should my report being marked as a dupp of 196720? or marked invalid?
If invalid, I'll post a comment on 196720.


Thank you for the enlightment.

Best regards.
Olivier

Comment 6

16 years ago
Well, from my point of view this is not a bug as Firebird behaves correctly when
performing the steps mentioned in the bug report. So duping this one because of
another bug should not be done as Firebird "works as designed" and no
malfunction is present.
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.