extend -remote xfeDoCommand(composemessage) to support adding attachments to the compose

RESOLVED DUPLICATE of bug 149126

Status

()

Core
X-remote
--
enhancement
RESOLVED DUPLICATE of bug 149126
15 years ago
15 years ago

People

(Reporter: Joe, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Currently, -remote has two ways to launch the messenger compose window:
1. -remote openURL(mailtoURL)
2. -remote xfeDoCommand(composemessage)
Neither supports to adding attachments. 
Since the commandline "mozilla -compose attachment=fileURL" has such a feature,
so it would be nice to extend xfeDoCommand to accept attachments args in
x-remote mode.

Reproducible: Always

Steps to Reproduce:
1.launch a process of mozilla if there isn't being one
2.launch: mozilla -remote "xfeDoCommand(composemessage)" to launch the compose
window
3.

Actual Results:  
Cannot insert any arguments such as to,cc, especially attachment to the compose
window launched.

Expected Results:  
be able to launch the compose window with informations passed as arguments, the
command would look like: 
mozilla -remote "xfeDoCommand(composemessage
to=some@mozilla.org,attachment=fileURL)"
(Reporter)

Comment 1

15 years ago
Currently, the XRemoteService handle the xfeDoCommand(composeMessage) by
converting to "mailto:" URL, and passing it to the mailtoURL handler.
I'm thinking maybe we can change it to openwindow with the messengercompose xul
as what xfeDoCommand(openBrowser) dose now.
thus we can also parse the arguments to accept to,cc,attachments.   

Comment 2

15 years ago
dupe of "Mail Client doesn't work correctly with Open Office with rpm builds"
that bug already has a patch

*** This bug has been marked as a duplicate of 149126 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.