Cannot get POP 3 messages from server sometimes

RESOLVED DUPLICATE of bug 127461

Status

MailNews Core
Backend
--
critical
RESOLVED DUPLICATE of bug 127461
15 years ago
10 years ago

People

(Reporter: Gottlieb Hansbauer, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030401 WebWasher 3.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030401 WebWasher 3.3

After waking up from suspend to ram mode Mozilla Mail doesnt get new messages
from pop3 server sometimes. Mozilla Mail hangs some time when checking for new
mails and then writes there are no new messages on the server. However with
another emailprogram the messages may be could be received. Also when the
computer is restarted Mozilla Mail gets the new messages. I use SSL to get the
new Messages.
Even restarting Mozilla Mail sometimes doent help.

Reproducible: Always

Steps to Reproduce:
1. Retrieve Messages
2. Suspend to Ram
3. Wake up
4. Retrieve Messages
Actual Results:  
no new messages coud be fetched

Expected Results:  
maybe cut the old connection to the pop3 server and establish a new one

Comment 1

15 years ago
I have experienced the same problem on Linux without using SSL on both 1.3 and 1.4.

Please see http://bugzilla.mozilla.org/show_bug.cgi?id=213581 which may be related.

I have been keeping nspr logs for some time to help isolate the problem.  I
recently reviewed the logs and found that the client stops asking the pop server
for mail.    A grep of "SEND: USER"  shows the following pattern for multiple
mail accounts on the same POP server.  The log is taken from 1.3 but I have had
the same problem on 1.4 (I didn't recognize it at the time and didn't keep the
log - sorry).

Many repetions of:
1081478944[806e250]: SEND: USER primary.userid
1081478944[806e250]: SEND: USER secondary.userid
...

Followed by repeated queries for the secondary user and no queries of the primary:
1081478944[806e250]: SEND: USER secondary.userid
...

BTW.  Is there a way to get imestamps into the nspr log?  It would be very helpful.

Thanks, David

Comment 2

15 years ago
I forgot to add that this happens in normal operation without the need to
suspend and resume. The open question is how long will this take.  Additionally,
I've noted that manually selecting Get Msgs, Get All Messages, or Get for a
specific account fails to query the POP server.   In all cases so far it has
been the primary account that has not been queried.

I installed from RPM's and my version info is as follows:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

I am also behind a firewall router appliance.

Comment 3

15 years ago
I'd almost thought this problem had vanished but it has reasserted itself.

This evening I restarted Mozilla Mail and only accessed the primary email account.
It has stopped responding to get message requests.  I retrieved email from the
secondary and now get all messages just retrieves emails from the secondary. 
(BTW. Both email addresses are hosted on the same server).

Again, in my case I am not suspending to RAM.

Any suggestions for further diagnosis?

David

Comment 4

15 years ago
Still happening, see http://bugzilla.mozilla.org/show_bug.cgi?id=127461
Multiple OS, Mozilla from 0.9.8 to 1.5b.

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 127461 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.