Problem with "View Image"

RESOLVED FIXED in Thunderbird0.6

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED FIXED
15 years ago
8 years ago

People

(Reporter: Goi, Assigned: Scott MacGregor)

Tracking

unspecified
Thunderbird0.6
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6

Whenever I try to view images within Thunderbird by right clicking on the image
and selected "View Image", a new Menu title bar will open, but this title bar
has nothing, and when I maximize/resize it, it is empty.

Reproducible: Always

Steps to Reproduce:
1. Open a mail with an inline image
2. Right click on the image
3. Select "View Image"

Actual Results:  
An empty title bar will popup.

Expected Results:  
Open another Thunderbird window with the image, or use the default system image
viewer to view the image

Using Thunderbird 20030503 build.

Comment 1

15 years ago
Happens for me too. Thunderbird build 2003-05-06, win32.
Thunderbird is currently pre-alpha und bugs should not go to bugzilla at the
moment because it's incomplete. Mscott means that you should use the Mozillazine
Forums for bug reports at the moment

-> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 3

15 years ago
.
Status: RESOLVED → UNCONFIRMED
Component: Mail Window Front End → Mail Window Front End
Product: MailNews → Thunderbird
Resolution: INVALID → ---
Version: Trunk → unspecified

Comment 4

15 years ago
.
Assignee: sspitzer → scott
QA Contact: esther → asa
Summary: Problem with "View Image" in Thunderbird → Problem with "View Image"

Comment 5

15 years ago
Confirming bug. This does happen. It should probably open up whatever the
default image viewer is for that image type. But, since thunderbird has a gecko
engine and can render images inline, then there's no reason a thunderbird window
can't render the image, so external calls may not be necessary.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

15 years ago
Happens also with signatures containing image URLs
(Reporter)

Comment 7

15 years ago
I don't think it happens for just Windows2000 either, so perhaps some others
that use it on other OSes could confirm the bug and change the affected OS field.

Updated

15 years ago
QA Contact: asa

Comment 8

15 years ago
Build 20030901 which is 0.2
Windows XP

I can confirm the same behavior with XP.

Comment 9

14 years ago
Confirming bug in Mozilla Thunderbird 0.4a (20031110) on Windows 2000 Pro.

Comment 10

14 years ago
As far as I know, the "View Image" option is only available by right clicking on
an image already visible in the viewing window/pane.  What’s the point of “View
Image” if you’re viewing the image anyway?  Unless there is a situation where a
placeholder is displaying instead of an image, I say that the item be removed
from the menu.

Comment 11

14 years ago
Yes, but if it's scaled, or clipped, or has transparency etc. it's nice to see
the image in its original context.  In some cases it is also necessary to view
the whole image if the page has frames or other artificial dimension constraints.
Also, "view image" is a necessity if you've activated the option to block remote
image loading-- it's the easiest way to know what's in that blank space short of
copying the URL into a browser!
*** Bug 236982 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

14 years ago
*** Bug 227751 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 15

14 years ago
Created attachment 144804 [details] [diff] [review]
fix
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird0.6
(Assignee)

Comment 16

14 years ago
fix checked in. Eventually it'd be nice if we could launch a browser or whatever
the default image viewer is....
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.