Closed Bug 204724 Opened 17 years ago Closed 17 years ago

ExcludeSelf doesn't work if having registered with an email containing capital letters

Categories

(Bugzilla :: Email Notifications, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: Wurblzap, Assigned: Wurblzap)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530 WebWasher 3.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530 WebWasher 3.3

The ExcludeSelf-feature doesnt't work if the the e-mail address used for
registering contains capital letters.
This is because BugMail.pm lacks an lc().
After putting this in, I'll add a patch to this.

Reproducible: Always

Steps to Reproduce:
1. Register with an e-mail containing a capital letter, e.g. JohnDoe@nowhere.net
2. Make sure your e-mail preferences at userprefs.cgi?tab=email have "Only email
me reports of changes made by other people" checked ("ExcludeSelf"-feature)
3. Add a comment to a bug

Actual Results:  
An e-mail informing me of the changes I made arrives.

Expected Results:  
There shouldn't have arrived an e-mail.
Attached patch PatchSplinter Review
This patch is against revision 1.3 of Bugzilla/BugMail.pm.
*** Bug 205364 has been marked as a duplicate of this bug. ***
This looks like a regression from bug 122900, which Myk checked in.

The fix looks simple and sane enough to me, but I'd like him to review it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #122660 - Flags: review?(myk)
Comment on attachment 122660 [details] [diff] [review]
Patch

r=myk
Attachment #122660 - Flags: review?(myk) → review+
Flags: approval+
Checked in.

Checking in BugMail.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/BugMail.pm,v  <--  BugMail.pm
new revision: 1.4; previous revision: 1.3
done

Thanks for the patch, Marc.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.18
Assignee: preed → wurblzap
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.